• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Mobile Push Notifications for XenForo

Mobile Push Notifications for XenForo 1.0.5

No permission to download
#61
@Alfa1 @Floyd R Turbo There was a config issue with the actual forum (not the add-on) that was causing a lot of different things to go haywire, our add-on included; found out what you meant when you said the box was in the footer, that is not normal behavior for the plugin.

The config issue was just fixed so everything should be operating normally as of now.
 

Lemminator

Well-known member
#62
@Alfa1 @Floyd R Turbo There was a config issue with the actual forum (not the add-on) that was causing a lot of different things to go haywire, our add-on included; found out what you meant when you said the box was in the footer, that is not normal behavior for the plugin.

The config issue was just fixed so everything should be operating normally as of now.
Thanks
 
#64
Turned this on for 1 usergroup (admin) to test and was thrown the following errors (appears to have locked up other usergroups):

Code:
Error: Call to a member function getId() on boolean - WebPush/_source/turnkeymobileapps/WebPush/src/Runtime.php:169
Generated By: Unknown Account, Today at 9:18 AM
Stack Trace
#0 /home/oakleyfo/public_html/WebPush/_source/turnkeymobileapps/WebPush/src/Runtime.php(145): WebPush\Runtime::userAuthToken(Array)
#1 /home/oakleyfo/public_html/library/WebPush/Listener.php(81): WebPush\Runtime::headInclude(Array)
#2 /home/oakleyfo/public_html/library/XenForo/CodeEvent.php(58): WebPush_Listener::template_hook('page_container_...', '\n\t<meta charset...', Array, Object(XenForo_Template_Public))
#3 /home/oakleyfo/public_html/library/XenForo/Template/Abstract.php(285): XenForo_CodeEvent::fire('template_hook', Array, 'page_container_...')
#4 /home/oakleyfo/public_html/internal_data/templates/S.2,L.1,PAGE_CONTAINER.php(356): XenForo_Template_Abstract->callTemplateHook('page_container_...', '\n\t<meta charset...', Array)
#5 /home/oakleyfo/public_html/library/XenForo/Template/Abstract.php(260): include('/home/oakleyfo/...')
#6 /home/oakleyfo/public_html/library/XenForo/Template/Abstract.php(191): XenForo_Template_Abstract->_renderInternal('/home/oakleyfo/...', Array)
#7 /home/oakleyfo/public_html/library/XenForo/Template/Public.php(110): XenForo_Template_Abstract->render()
#8 /home/oakleyfo/public_html/library/XenForo/ViewRenderer/HtmlPublic.php(140): XenForo_Template_Public->render()
#9 /home/oakleyfo/public_html/library/XenForo/FrontController.php(639): XenForo_ViewRenderer_HtmlPublic->renderContainer('\n\n\n\n\n\n\n\n\n\n\n\n\n<f...', Array)
#10 /home/oakleyfo/public_html/library/XenForo/FrontController.php(158): XenForo_FrontController->renderView(Object(XenForo_ControllerResponse_View), Object(XenForo_ViewRenderer_HtmlPublic), Array)
#11 /home/oakleyfo/public_html/index.php(13): XenForo_FrontController->run()
#12 {main}
Request State
array(3) {
  ["url"] => string(53) "https://www.oakleyforum.com/account/alert-preferences"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(0) {
  }
}
Delete...Close
 

Floyd R Turbo

Well-known member
#66
Can you please use a version number in the filename when you update the listing? It always downloads as "xenforo-1.x.zip which in and of itself doesn't really follow in line with what most poeple do for a naming convention. You should at least have the filename include the actual name of tha addon and version number. I'm one of those people that hoards old versions (disk space is cheap) and also sometimes I only get around to doing updates monthly so if more than one version comes out between updates I like to be able to check that quick. I can't tell any of that with yours.

I would recommend using this format: "addon-tma-mobile-push-notifications-xenforo-1.0.4.zip" then just update the version number in the title with each update.

Just a friendly suggestion.
 
#71
turnkeymobileapps updated Mobile Push Notifications for XenForo with a new update entry:

Fix: Non-delivery of Notifications

We have discovered a major issue that was causing push notifications to not be sent. This fix does not require an update, but:
  • Users not receiving alerts must clear their cookies and log back in
  • If your plugin was uninstalled, contact us for a license key to re-activate it (required)
We also discovered an issue that either delays or prevents activation of our service; this issue is caused by Cloudflare, and you must whitelist this URL:

yourdomain.com/web_push.php
Read the rest of this update entry...