1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

member profile error

Discussion in 'Troubleshooting and Problems' started by majdi, Feb 23, 2011.

  1. majdi

    majdi Well-Known Member

  2. Brogan

    Brogan XenForo Moderator Staff Member

    Is this for all members?

    Is there anything in the ACP server error log or the apache log?
     
  3. majdi

    majdi Well-Known Member

  4. Brogan

    Brogan XenForo Moderator Staff Member

    It sounds like the data wasn't imported correctly.

    Was it a vB import or from another forum software?
     
  5. majdi

    majdi Well-Known Member

    ipb through vb
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    Is this a final/working installation or is it just testing at the moment?

    If possible it would be good if you could do the IPB to vB import again and check/update the users and groups there before importing to XenForo.
     
  7. majdi

    majdi Well-Known Member

    i still have the vb copy, the same user profile is loading just fine and members are not in the guest group as it is the case with xf
    ps: this is a live version, i need a quick solution !
     
  8. Mike

    Mike XenForo Developer Staff Member

    Admin CP, Tools > Server Error Log should have more details.
     
  9. majdi

    majdi Well-Known Member

     
  10. Mike

    Mike XenForo Developer Staff Member

    That's the wrong error - it's from the importer issue that you reported. There *should* be a more recent one.

    If not, add this to library/config.php:

    $config['debug'] = true;

    And go to the profile that errors for more info. (Remove the line after.)
     
  11. majdi

    majdi Well-Known Member

  12. Mike

    Mike XenForo Developer Staff Member

    That's spawned from the same error as before. Try these queries:

    UPDATE xf_user_profile SET dob_month = 12 WHERE dob_month > 12;
    UPDATE xf_user_profile SET dob_month = 1 WHERE dob_month < 1;
    UPDATE xf_user_profile SET dob_day = 31 WHERE dob_day > 31;
    UPDATE xf_user_profile SET dob_day = 1 WHERE dob_day < 1;

    The fixes I make for the import issue will prevent this from occurring.
     
    majdi likes this.
  13. Mike

    Mike XenForo Developer Staff Member

    Additionally, take that debug mode line out. You don't want to leave it on a production server. :)
     
  14. majdi

    majdi Well-Known Member

    that fixed it. thanks
    what about users set to guest ?
     
  15. Mike

    Mike XenForo Developer Staff Member

    That would've occurred in your initial IPB to vB conversion, so it's not trivial to change after the fact except by editing the users in the admin CP.
     

Share This Page