XF 1.1 Mark as read problem

Binari0

Member
I have the following problem in my forum. When I want to make a forum as read display this:




In Xenforo display this:



Any suggestions? From already thank you.
 

Onimua

Well-known member
Not the language, the templates–the HTML of that dialog. Can you post the contents of your forum_mark_read template?
 

Binari0

Member
Here:

Code:
<xen:title>{xen:phrase mark_forums_read}</xen:title>
 
<form action="{xen:link forums/-/mark-read}" method="post" class="xenForm formOverlay AutoValidator" data-redirect="on">
 
    <xen:if is="{$forum}">
        <p>{xen:phrase which_forums_do_you_want_to_mark_as_read}</p>
       
        <dl class="ctrlUnit">
            <dt></dt>
            <dd>
                <ul>
                    <li><label><input type="radio" name="node_id" value="{$forum.node_id}" checked="checked" /> {$forum.title}</label></li>
                    <li><label><input type="radio" name="node_id" value="0" /> {xen:phrase mark_all_forums_read}</label></li>
                </ul>
            </dd>
        </dl>
       
        <dl class="ctrlUnit submitUnit">
            <dt></dt>
            <dd>
                <input type="submit" value="{xen:phrase mark_forums_read}" class="button primary" />
            </dd>
        </dl>
    <xen:else />   
        <p>{xen:phrase you_sure_you_want_to_mark_all_forums_read}</p>
       
        <dl class="ctrlUnit submitUnit">
            <dt></dt>
            <dd>
                <input type="submit" value="{xen:phrase mark_all_forums_read_button}" class="button primary" />
            </dd>
        </dl>   
    </xen:if>
 
    <input type="hidden" name="date" value="{$markDate}" />
    <input type="hidden" name="_xfToken" value="{$visitor.csrf_token_page}" />
    <input type="hidden" name="_xfConfirm" value="1" />
</form>
 

Onimua

Well-known member
And this is the same if you do it on the default style (not the one you have as default on your site)?
 

Binari0

Member
Yes, is the default, we have 2 styles hardware and games. This is games:

Code:
<xen:title>{xen:phrase mark_forums_read}</xen:title>
 
<form action="{xen:link forums/-/mark-read}" method="post" class="xenForm formOverlay AutoValidator" data-redirect="on">
 
    <xen:if is="{$forum}">
        <p>{xen:phrase which_forums_do_you_want_to_mark_as_read}</p>
       
        <dl class="ctrlUnit">
            <dt></dt>
            <dd>
                <ul>
                    <li><label><input type="radio" name="node_id" value="{$forum.node_id}" checked="checked" /> {$forum.title}</label></li>
                    <li><label><input type="radio" name="node_id" value="0" /> {xen:phrase mark_all_forums_read}</label></li>
                </ul>
            </dd>
        </dl>
       
        <dl class="ctrlUnit submitUnit">
            <dt></dt>
            <dd>
                <input type="submit" value="{xen:phrase mark_forums_read}" class="button primary" />
            </dd>
        </dl>
    <xen:else />   
        <p>{xen:phrase you_sure_you_want_to_mark_all_forums_read}</p>
       
        <dl class="ctrlUnit submitUnit">
            <dt></dt>
            <dd>
                <input type="submit" value="{xen:phrase mark_all_forums_read_button}" class="button primary" />
            </dd>
        </dl>   
    </xen:if>
 
    <input type="hidden" name="date" value="{$markDate}" />
    <input type="hidden" name="_xfToken" value="{$visitor.csrf_token_page}" />
    <input type="hidden" name="_xfConfirm" value="1" />
</form>
The Style is defined in the extra.css
 

Jake Bunce

XenForo moderator
Staff member
Also try reverting this template:

Admin CP -> Appearance -> Templates -> navigation

In particular, the code for the Forums tab:

Rich (BB code):
		<!-- forums -->
		<xen:if is="{$tabs.forums}">
			<li class="navTab forums {xen:if $tabs.forums.selected, 'selected', 'Popup PopupControl PopupClosed'}">
			
				<a href="{$tabs.forums.href}" class="navLink">{$tabs.forums.title}</a>
				<a href="{$tabs.forums.href}" class="SplitCtrl" rel="Menu"></a>
				
				<div class="{xen:if {$tabs.forums.selected}, 'tabLinks', 'Menu JsOnly tabMenu'}">
					<div class="primaryContent menuHeader">
						<h3>{$tabs.forums.title}</h3>
						<div class="muted">{xen:phrase quick_links}</div>
					</div>
					<ul class="secondaryContent blockLinksList">
					<xen:hook name="navigation_tabs_forums">
						<xen:if is="{$visitor.user_id}"><li><a href="{xen:link 'forums/-/mark-read', $forum, 'date={$serverTime}'}" class="OverlayTrigger">{xen:phrase mark_forums_read}</a></li></xen:if>
						<xen:if is="{$canSearch}"><li><a href="{xen:link search, '', 'type=post'}">{xen:phrase search_forums}</a></li></xen:if>
						<xen:if is="{$visitor.user_id}"><li><a href="{xen:link 'watched/threads'}">{xen:phrase watched_threads}</a></li></xen:if>
						<li><a href="{xen:link 'find-new/threads'}">{xen:phrase whats_new}</a></li>
					</xen:hook>
					</ul>
				</div>
			</li>
		</xen:if>
 

Binari0

Member
Also try reverting this template:

Admin CP -> Appearance -> Templates -> navigation

In particular, the code for the Forums tab:

Rich (BB code):
<!-- forums -->
<xen:if is="{$tabs.forums}">
<li class="navTab forums {xen:if $tabs.forums.selected, 'selected', 'Popup PopupControl PopupClosed'}">
 
<a href="{$tabs.forums.href}" class="navLink">{$tabs.forums.title}</a>
<a href="{$tabs.forums.href}" class="SplitCtrl" rel="Menu"></a>
 
<div class="{xen:if {$tabs.forums.selected}, 'tabLinks', 'Menu JsOnly tabMenu'}">
<div class="primaryContent menuHeader">
<h3>{$tabs.forums.title}</h3>
<div class="muted">{xen:phrase quick_links}</div>
</div>
<ul class="secondaryContent blockLinksList">
<xen:hook name="navigation_tabs_forums">
<xen:if is="{$visitor.user_id}"><li><a href="{xen:link 'forums/-/mark-read', $forum, 'date={$serverTime}'}" class="OverlayTrigger">{xen:phrase mark_forums_read}</a></li></xen:if>
<xen:if is="{$canSearch}"><li><a href="{xen:link search, '', 'type=post'}">{xen:phrase search_forums}</a></li></xen:if>
<xen:if is="{$visitor.user_id}"><li><a href="{xen:link 'watched/threads'}">{xen:phrase watched_threads}</a></li></xen:if>
<li><a href="{xen:link 'find-new/threads'}">{xen:phrase whats_new}</a></li>
</xen:hook>
</ul>
</div>
</li>
</xen:if>
Thank! This worsk! In m forum tabs had this:

Code:
<!-- forums -->
        <xen:if is="{$tabs.forums}">
            <li class="navTab forums {xen:if $tabs.forums.selected, 'selected', 'Popup PopupControl PopupClosed'}">
           
                <a href="{$tabs.forums.href}" class="navLink">{$tabs.forums.title}</a>
                <a href="{$tabs.forums.href}" class="SplitCtrl" rel="Menu"></a>
               
                <div class="{xen:if {$tabs.forums.selected}, 'tabLinks', 'Menu JsOnly tabMenu'}">
                    <div class="primaryContent menuHeader">
                        <h3>{$tabs.forums.title}</h3>
                        <div class="muted">{xen:phrase quick_links}</div>
                    </div>
                    <ul class="secondaryContent blockLinksList">
                    <xen:hook name="navigation_tabs_forums">
                        <xen:if is="{$visitor.user_id}"><li><a href="{xen:link 'forums/-/mark-read', '', 'date={$serverTime}'}" class="OverlayTrigger">{xen:phrase mark_all_forums_read}</a></li></xen:if>
                        <xen:if is="{$canSearch}"><li><a href="{xen:link search, '', 'type=post'}">{xen:phrase search_forums}</a></li></xen:if>
                        <xen:if is="{$visitor.user_id}"><li><a href="{xen:link 'watched/threads'}">{xen:phrase watched_threads}</a></li></xen:if>
                        <li><a href="{xen:link 'find-new/threads'}">{xen:phrase whats_new}</a></li>
                    </xen:hook>
                    </ul>
                </div>
            </li>
        </xen:if>
 
Top