Sorry this didn't make it in time for 1.0.2. (I've been going over my early work and finding things I glossed over.) The phrase "mark_all_forums_read" is being used in three places that I know of: (A) As a link Where: Quick Link under the Forums tab in the navbar. (B) As a dialog title Where: Confirmation dialog displayed by the above link. (C) As a button Where: Confirmation dialog displayed by the above link. In Japanese, each of these needs to be slightly different for the reasons explained previously. Please replace instance (B) with an identical new phrase, "mark_all_forums_read_title". Please replace instance (C) with an identical new phrase, "mark_all_forums_read_button".