• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Loading Problems (And download)

#1
Hello,

I have just installed Xenforo on my new VPS and have encountered some problems which are causing me quite a few issues. The first problem is whenever I try to download Xenforo from the customers area It only downloads a file which is 5.4MB, this is even when I uncheck "Download upgrade package only" the file size also remains the same if I keep "Download upgrade package only" checked. I am not sure that something is wrong here but it would make sense if it was, you see my other problem is the admin panel and the main forums directory page load fine however If I was to say click on a category it would give me this error
Not Found

The requested URL /forums/2/ was not found on this server.

Apache/2.2.16 (Debian) Server at 209.141.53.231 Port 80

This happens for any link I click except for Forums, Home or Admin Panel. I was looking into this and it occurred to me that the files are probably not being included in the download.

If anyone has any ideas what is going wrong or can help me fix the problem that would be great! Thanks
 

Brogan

XenForo moderator
Staff member
#2
Both .zip files are 5.4MB.

What is the difference between the upgrade and full packages?
The upgrade package does not include the following files and directories:
.htaccess
library/config.php
data
internal_data

http://xenforo.com/community/threads/frequently-asked-questions.5183/#post-180455

The error related to categories could be due to the RewriteBase.
See the htaccess file for details on that.

Code:
# If you are having problems with the rewrite rules, remove the "#" from the
# line that begins "RewriteBase" below. You will also have to change the path
# of the rewrite to reflect the path to your XenForo installation.
# RewriteBase /community
 
#3
Both .zip files are 5.4MB.

What is the difference between the upgrade and full packages?
The upgrade package does not include the following files and directories:
.htaccess
library/config.php
data
internal_data

http://xenforo.com/community/threads/frequently-asked-questions.5183/#post-180455

The error related to categories could be due to the RewriteBase.
See the htaccess file for details on that.

Code:
# If you are having problems with the rewrite rules, remove the "#" from the
# line that begins "RewriteBase" below. You will also have to change the path
# of the rewrite to reflect the path to your XenForo installation.
# RewriteBase /community
I went ahead and got the file and removed the # however the path I am not sure if I did it right. Since I have all these files put directly into public_html and I dont have any /community ect. at the end of my link. Because of this I left it blank, I still went ahead and saved the file however it did not work I still got the same error. I also tried setting the link to /public_html and it did not work. Is there some sort of Xenforo reload command I need to do?
 

Tracy Perry

Well-known member
#4
I went ahead and got the file and removed the # however the path I am not sure if I did it right. Since I have all these files put directly into public_html and I dont have any /community ect. at the end of my link. Because of this I left it blank, I still went ahead and saved the file however it did not work I still got the same error. I also tried setting the link to /public_html and it did not work. Is there some sort of Xenforo reload command I need to do?
Is this a managed or unmanaged VPS?
If it is your root to your WWW folder then ReWriteBase / should work. You do have the apache mod_rewrite installed and enabled, correct?
What is throwing me is you refer to /public_html, which indicates a shared hosting service or you are using the Apache mod userdir. Under all Apache installations I've done on a multitude of Linux versions the base Apache WWW is located at /var/www, and that would be where you would locate your files at (if it is a singular domain install - I have about 4 domains running so I point each at a directory off the base /var/www.
Note, I'm running on an unmanaged VPS (unless you consider me the manager :p), so if your is managed I will have to bow out to others who are familiar with a managed VPS setup.
 

Jake Bunce

XenForo moderator
Staff member
#5
Possible causes of friendly URLs not working (usually manifests as "404 not found" error on forum pages):

1) The .htaccess file is not in place in your forum directory.

2) Sometimes you need to specify RewriteBase in your .htaccess file (specify the name of your forum directory):

RewriteBase /xenforo

3) Your server doesn't have mod_rewrite installed. Consult with your host about this.

4) Your server doesn't have AllowOverride enabled:

http://httpd.apache.org/docs/2.0/mod/core.html#allowoverride

Consult with your host about this.
 
#6
Is this a managed or unmanaged VPS?
If it is your root to your WWW folder then ReWriteBase / should work. You do have the apache mod_rewrite installed and enabled, correct?
What is throwing me is you refer to /public_html, which indicates a shared hosting service or you are using the Apache mod userdir. Under all Apache installations I've done on a multitude of Linux versions the base Apache WWW is located at /var/www, and that would be where you would locate your files at (if it is a singular domain install - I have about 4 domains running so I point each at a directory off the base /var/www.
Note, I'm running on an unmanaged VPS (unless you consider me the manager :p), so if your is managed I will have to bow out to others who are familiar with a managed VPS setup.
It is unmanaged, also the directory is /srv/www nor /var/www
 

Tracy Perry

Well-known member
#7
It is unmanaged, also the directory is /srv/www nor /var/www
What OS (out of curiosity). Debian, Ubuntu, CentOS all put it in /var/www as far as I know. In any case, you made sure that mod_rewrite was enabled (it is by default in the supplied .htaccess) but unless you install the module some installs of Apache it is not standard.
 
#8
What OS (out of curiosity). Debian, Ubuntu, CentOS all put it in /var/www as far as I know. In any case, you made sure that mod_rewrite was enabled (it is by default in the supplied .htaccess) but unless you install the module some installs of Apache it is not standard.
I am running Debian 6, and running Apache2

Here is what my htaccess:
#Mod_security can interfere with uploading of content such as attachments. If you
#cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
#SecFilterEngine Off
#SecFilterScanPOST Off
#</IfModule>

ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 500 default

<IfModule mod_rewrite.c>
RewriteEngine On

#If you are having problems with the rewrite rules, remove the "#" from the
#line that begins "RewriteBase" below. You will also have to change the path
#of the rewrite to reflect the path to your XenForo installation.
RewriteBase /public_html

#This line may be needed to enable WebDAV editing with PHP as a CGI.
#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -l [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^.*$ - [NC,L]
RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
RewriteRule ^.*$ index.php [NC,L]
</IfModule>
 
#9
P.S. I cannot log in either because the login page is not working either, I think what ill do is re-install and see what this does. Also I did just before this happened enable Friendly URL's without modifying anything on the server and now this does not work, however I did get the chance to change it back however it still did not work. What exactly should I be doing to the server to make Friendly URL's dont ruin things?
 

Tracy Perry

Well-known member
#10
I am running Debian 6, and running Apache2

#If you are having problems with the rewrite rules, remove the "#" from the
#line that begins "RewriteBase" below. You will also have to change the path
#of the rewrite to reflect the path to your XenForo installation.
RewriteBase /public_html
And all files/directories are located then under /srv/www/public_html? and in /etc/Apache2/mods-enabled you have a symbolic link to rewrite.load (@rewrite.load )?
These are the modules shown in my mods-enabled for my old Apache2 install (running nginx now).
@alias.conf
@alias.load
@auth_basic.load
@auth_digest.load
@authn_file.load
@authz_default.load
@authz_groupfile.load
@authz_host.load
@authz_user.load
@autoindex.conf
@autoindex.load
@cache.load
@cgi.load
@deflate.conf
@deflate.load
@dir.conf
@dir.load
@disk_cache.conf
@disk_cache.load
@env.load
@fcgid.conf
@fcgid.load
@geoip.conf
@geoip.load
@mime.conf
@mime.load
@negotiation.conf
@negotiation.load
@php5.conf
@php5.load
@python.load
@reqtimeout.conf
@reqtimeout.load
@rewrite.load
@ruby.load
@setenvif.conf
@setenvif.load
@status.conf
@status.load
@unique_id.load
 
#11
Update: I managed to get into my admin panel and disabled friendly URL's now it is working and looking into it I am not sure that my host has mod_rewrite on, I will look into that.
 

Tracy Perry

Well-known member
#12
P.S. I cannot log in either because the login page is not working either, I think what ill do is re-install and see what this does. Also I did just before this happened enable Friendly URL's without modifying anything on the server and now this does not work, however I did get the chance to change it back however it still did not work. What exactly should I be doing to the server to make Friendly URL's dont ruin things?
If you enabled smart URLS and they are not working, it sounds a LOT like you don't have the mod_rewrite installed/enabled. If you have SSH access, check your /etc/Apache2/mods-available and make sure that it is listed there. If so, make a symbolic link to it in your /etc/Apache2/mods-enabled directory.
 

Tracy Perry

Well-known member
#13
First thing before I did that would be to SSH into your debian box and enter the command a2enmod rewrite. If you have the mod_rewrite installed this will enable it for apache. Then issue an /etc/init.d/apache2 reload and see how it does.

Here is another Gotcha that Jake referred to. You need to check your /etc/apache2/sites-available/whatever definition you used (whether default or a custom one) and check the following:

Find the following:
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all


and change it to

Options Indexes FollowSymLinks MultiViews
AllowOverride all
Order allow,deny
allow from all

and finally restart Apache:

/etc/init.d/apache2 restart
 

Mike

XenForo developer
Staff member
#14
If this is your own VPS and you just installed Apache yourself, it's almost certainly the AllowOverride thing. It defaults to None (off).