1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[LN] Blog [Deleted]

Discussion in 'Add-on Releases' started by Onimua, Jan 31, 2012.

  1. Onimua

    Onimua Well-Known Member

    Lkp.Chester likes this.
  2. Onimua

    Onimua Well-Known Member

  3. Onimua

    Onimua Well-Known Member

  4. Adam Howard

    Adam Howard Well-Known Member

    When you switch to a paid version, will it include a converter for those making the switch from vBulletin 4 ?
     
  5. Onimua

    Onimua Well-Known Member

    No, that's handled by the Importer Suite which is another add-on in the works.
     
  6. Adam Howard

    Adam Howard Well-Known Member

    [​IMG]

    One of the things I don't want to see from XenForo is every useful app become a paid app. It's on of the things I absolutely hated about IPB. Please tell me this Importer Suite will be a free alternative.
     
  7. Onimua

    Onimua Well-Known Member

    Of course. o_O
     
  8. Adam Howard

    Adam Howard Well-Known Member

    Thank you :cool:

    I know, it may have seen obviously transparent and I know you Onumua to be very respectful, who I believe wouldn't do such a thing.... But I had to ask (sorry).

    Would you believe on IPB they even were starting to sell BB Code? :eek: (I can't imagine anyone buying it)
     
  9. Onimua

    Onimua Well-Known Member

    Unless someone comes up with a bug report soon, the last free update to LNBlog will be released this week. :)
     
  10. mrb1972

    mrb1972 Active Member

    Great news - is the paid verson still on course for Q1 2012? Its the final part of the jigsaw I need to launch my website ;)
     
  11. Onimua

    Onimua Well-Known Member

    Is there a particular reason you're waiting for it?
     
  12. mrb1972

    mrb1972 Active Member

    Well I im converting my current VB4 + wordpress site to xenforo and wanted to use your blog addon in place of wordpress, I have a test site setup and managed to convert my wordpress blogs and comments into LNblog, I could get away with beta3 but as beta4 was is a rewrite I thought it would be better to wait.

    I get the feeling beta4 isnt due anytime soon then?
     
  13. Onimua

    Onimua Well-Known Member

    It was but I changed gears to rewriting everything in 1.1 after some thinking. If I do the rewrite now I might as well just call it Beta 1, starting all over again by its very nature, and I don't want to have people wait even longer for a stable build which I know has been dragged out for far too long (yes folks, don't need to tell me again ;)).

    A very light sprinkle of one or two features will be in Beta 4, and then it's off to RC/stable so people can feel confident in using "stable" software and I can switch gears to dealing with 1.1 of the Blog and prepare for Beta 1 of Storefront.

    So if you want to wait until 1.0 Beta 3B, you can and upgrade through to 1.0 stable as it comes out. We can all work through 1.0 -> 1.1 of the blog together down the line. :)
     
  14. mrb1972

    mrb1972 Active Member

    Ok I think that makes sense - ;) so your releasing the last free version, 1.0 Beta3b this week?
    Then beta 4 and so on and the rewrite version 1.1 coming further down the line?

    Is that correct?
     
  15. SchmitzIT

    SchmitzIT Well-Known Member

    We ran into a tiny issue that I hope will not be too hard to solve.

    Despite our anti-spammer methods, occasionally one manages to sneak through. In this case, he/she/it started a blogpost, which was quickly nuked after it was spotted. However, the XenPorta blog module still shows it as a recent entry.

    Is there any way to handle these?

    Thanks :)
     
  16. Onimua

    Onimua Well-Known Member

    Yes.
    The blog doesn't have any links to XenForo's Spam Cleaner actually. I'll deal with that as fast as I can in that case and put it into 3B. That should clear things up... any other things you may have spotted?
     
    TheVisitors and SchmitzIT like this.
  17. SchmitzIT

    SchmitzIT Well-Known Member

    Cannot say I have :) Other than this minor issue, it's working flawlessly.
     
  18. yavuz

    yavuz Well-Known Member

    I keep getting these errors below:

    Code:
    ErrorException: Argument 1 passed to LNBlog_ControllerPublic_EntryComment::getCommentSpecificRedirect() must be an array, boolean given, called in /home/user/public_html/library/LNBlog/ControllerPublic/EntryComment.php on line 26 and defined - library/LNBlog/ControllerPublic/EntryComment.php:39
    Generated By: user, Bugün 06:20
     
    #0 /home/user/public_html/library/LNBlog/ControllerPublic/EntryComment.php(39): XenForo_Application::handlePhpError(4096, 'Argument 1 pass...', '/home/user/...', 39, Array)
    #1 /home/user/public_html/library/LNBlog/ControllerPublic/EntryComment.php(26): LNBlog_ControllerPublic_EntryComment->getCommentSpecificRedirect(false, false, 5)
    #2 /home/user/public_html/library/XenForo/FrontController.php(310): LNBlog_ControllerPublic_EntryComment->actionIndex()
    #3 /home/user/public_html/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #4 /home/user/public_html/index.php(13): XenForo_FrontController->run()
    #5 {main}
    
    array(3) {
      ["url"] => string(50) "http://www.site.com/entry-comments/89/"
      ["_GET"] => array(0) {
      }
      ["_POST"] => array(0) {
      }
    }
     
     
  19. Matthew2D

    Matthew2D Active Member

    Pure awesomeness.
     
  20. Onimua

    Onimua Well-Known Member

    Hm... alright, will look into it.
     
    yavuz likes this.

Share This Page