1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Live Update 4.0.1

Automatically updates your alert / inbox, adds indicator to favicon.

  1. Naatan

    Naatan Well-Known Member

    Naatan submitted a new resource:

    AjaxPolling (version 0.1) - Automatically updates your alert / inbox tooltip when you receive notifications.

    Read more about this resource...
     
    t0daY, erich37 and yavuz like this.
  2. DRE

    DRE Well-Known Member

    Does xenforo already do this?
     
  3. yavuz

    yavuz Well-Known Member

    Nice one Naatan. I tried ajaxboy's AutoUpdater but couldn't get it work. A question, does it have any side affects over server load & performance?

    Thank You.
     
  4. yavuz

    yavuz Well-Known Member

    You have to triger something to get updates (write a message, hover on something etc) ...
     
  5. Naatan

    Naatan Well-Known Member

    This all depends on the amount of active users you have and the time they spend on a page. It's not going to blow up your server by any means, but you might notice a small increase in load, which is only natural with a feature like this.
     
    yavuz likes this.
  6. DRE

    DRE Well-Known Member

    This add-on won't install. Parse error: syntax error, unexpected T_STATIC in /home/user/public_html/library/AjaxPolling/Listener.php on line 24
     
  7. Naatan

    Naatan Well-Known Member

  8. Naatan

    Naatan Well-Known Member

    I posted an updated version that fixes this, sorry for the inconvenience.
     
  9. giorgino

    giorgino Well-Known Member

  10. Naatan

    Naatan Well-Known Member

    giorgino likes this.
  11. yavuz

    yavuz Well-Known Member

    Same here, I had users report that editor is breaking using IE 7, 8 and 9.
     
  12. DRE

    DRE Well-Known Member

    A poster using IE8 are unable to post with this modification. I turned it off and she was able to post.

    Disabled for now.
     
  13. Naatan

    Naatan Well-Known Member

  14. giorgino

    giorgino Well-Known Member

    Hi Naatan, seems that sometimes alerts don't show up...
     
  15. Naatan

    Naatan Well-Known Member

    I can't do much with that information unless you have some sort of error log or a way of reproducing the issue. Simply by what you've stated there can be many different reasons why this would happen, most of which have nothing to do with the addon in particular.

    Keep in mind that this addon just refreshes your notification counts automatically on an interval, it does not actually send alerts. So if you are not receiving an alert you feel you should be then that's not a bug with the addon.
     
  16. giorgino

    giorgino Well-Known Member

    You're right...

    The issue is that the notification counts don't been refreshed on (for example) new messages

    If I discover how to reproduce the bug, report back.
    Disabled for now :(
     
  17. Naatan

    Naatan Well-Known Member

    If you want I could see if I can debug it for you, as I can't reproduce any issue of the sort myself.

    To do so I would need 2 accounts on your forums, to send myself messages and check the result. You can delete them after I'm done debugging.
     
  18. giorgino

    giorgino Well-Known Member

    Yes it's great! :)
    PM'ed you
     
  19. Naatan

    Naatan Well-Known Member

  20. Naatan

    Naatan Well-Known Member

    Fixed in latest version.
     

Share This Page