1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Last questions

Discussion in 'Troubleshooting and Problems' started by Pierre Boulanger, Aug 2, 2013.

  1. Pierre Boulanger

    Pierre Boulanger Active Member

    After a month hopfully today we will go live but there are a couple of issues to address:

    1) There is an issue with Global moderators. Even though they have all the required permission and appear in user lists correctly in their profile appear as members! 2013-08-02 10_25_35-Flaminio Bertoni _ my2cv.gr - The story of a legend.jpg

    2013-08-02 10_25_54-my2cv.gr - The story of a legend.jpg

    2) Is it possible to center small user names?
    2013-08-02 10_25_02-Final Migration - Readme _ my2cv.gr - The story of a legend.jpg
     

    Attached Files:

  2. Pierre Boulanger

    Pierre Boulanger Active Member

    3) In Style Properties: Responsive Design I'm using the following settings
    2013-.jpg


    In iPhone looking like:

    Dc1783.PNG

    Any suggestions?
     
  3. Brogan

    Brogan XenForo Moderator Staff Member

    1. You have not made them a moderator. I suspect you have only added them to the user group.

    2. Add to EXTRA.css:
    Code:
    .messageUserBlock a.username {
    text-align: center;
    }
    3. I suspect this is due to wrapping in the header area but impossible to debug from a screenshot.
     
    Pierre Boulanger and Shelley like this.
  4. Shelley

    Shelley Well-Known Member

    2. Regarding centering the username this will however center all usernames. Add the following in EXTRA.CSS template.

    edit: Nija'd by @Brogan

    Code:
    .messageUserBlock .username {text-align: center;}
     
  5. EQnoble

    EQnoble Well-Known Member

    I don't think there is a simple one liner just to center names under a certain length, all center or none.

    Code:
    <div style="float:right; text-align:left; font-size:24px; color:white; width:60%; margin-top:40px;">The story of a legend</div>
    this is your problem, you need to refactor that. It is not your options setup in the control panel that is the problem.

    If you replace that with the following in there and let me know when it is in place I will write you some css to make it work.
    Code:
    <div class="storyOfLegend">The story of a legend</div>
     
  6. Pierre Boulanger

    Pierre Boulanger Active Member

    Thanks EQnoble!
    Where i can find that? Sorry I'm a noob
     
  7. Brogan

    Brogan XenForo Moderator Staff Member

    You have probably added it to the ad_header template.

    I would use a media query to hide the text once the width drops below a certain size.
    You can do that by adding a class to the div like so:
    Code:
    <div class="my-header-text">The story of a legend</div>
    Then using something like the following:
    Code:
    <style type="text/css">
    .my-header-text {
    float: right;
    text-align:left;
    font-size:24px;
    color:white;
    width:60%;
    margin-top:40px;
    }
    
    <xen:if is="@enableResponsive">
        @media (max-width:400px) {
            .my-header-text  {
            display: none;
            }
        }
    </xen:if>
    </style>
     
  8. Pierre Boulanger

    Pierre Boulanger Active Member

    Can you please write step by step what i must do?
    Thanks Brogan
     
  9. Brogan

    Brogan XenForo Moderator Staff Member

    The full ad_header template would be something like:

    Code:
    <style type="text/css">
    .my-header-text {
    float: right;
    text-align:left;
    font-size:24px;
    color:white;
    width:60%;
    margin-top:40px;
    }
    
    <xen:if is="@enableResponsive">
        @media (max-width:400px) {
            .my-header-text  {
            display: none;
            }
        }
    </xen:if>
    </style>
    
    <div class="my-header-text">The story of a legend</div>
    Change the 400px to suit.
     
    Pierre Boulanger likes this.
  10. Pierre Boulanger

    Pierre Boulanger Active Member

    It would be also great if you can tell me where i can change the "New" color from :)

    2013-08-02 12_33_11-1.2 - Last questions _ XenForo Community.jpg
     
  11. Brogan

    Brogan XenForo Moderator Staff Member

    Style Properties -> Message Elements -> New Indicator
     
    Pierre Boulanger likes this.
  12. Pierre Boulanger

    Pierre Boulanger Active Member

    Both suggestions worked perfectly!!!!!!!!!!!!!!! (y):cool:
     
  13. Rob

    Rob Well-Known Member

    I find the level and extent of support here quite refreshing and very humbling
     
  14. Pierre Boulanger

    Pierre Boulanger Active Member

    When i like a topic i see the link and not the topic title etc... Any ideas please? 2013-08-02 16_22_28-2cv by Francesco _ my2cv.gr - The story of a legend.jpg
     
  15. Pierre Boulanger

    Pierre Boulanger Active Member

    A couple of issues more..

    For some reason "Share via google+" not working

    2013-08-02 20_51_01-my2cv.gr - The story of a legend.jpg

    2013-08-02 20_51_38-my2cv.gr - The story of a legend.jpg

    Thanks :(
     
  16. Pierre Boulanger

    Pierre Boulanger Active Member

    Any suggestions please?:)
     
  17. Jeremy

    Jeremy XenForo Moderator Staff Member

    Have you followed the trouble shooting that Google is suggesting?
     
  18. Pierre Boulanger

    Pierre Boulanger Active Member

    Yes. I just don't understand the:

    Apps user: If your administrator hasn't enabled Google+ for your domain, you won't be able to sign up for a Google+ account to use the +1 button.
    Is anything that i must do on my forum or in my google+ account?
     
  19. Pierre Boulanger

    Pierre Boulanger Active Member

    2013-08-03 11_39_13-my2cv.gr - The story of a legend.jpg

    I'm logged in

    As you can see in xenforo there is no problem
     

    Attached Files:

  20. Mike

    Mike XenForo Developer Staff Member

    It appears that your forums are closed, thus G+ can't read the page, so you'll get that error.
     

Share This Page