1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Unmaintained [KL] Language Specific Forums 0.9.2

Filter Forums by User Language

  1. katsulynx

    katsulynx Well-Known Member

    katsulynx submitted a new resource:

    [KL] Language Specific Forums - Filter Forums by User Language

    Read more about this resource...
     
    Last edited: Oct 19, 2015
    RhysR and rafass like this.
  2. JustinHawk

    JustinHawk Active Member

    You made a Title mistake in description :)
     
    katsulynx likes this.
  3. Kintaro

    Kintaro Well-Known Member

    wow!

    is this working with RM?
    is it easy for addon devs to support this on their addons?
     
  4. katsulynx

    katsulynx Well-Known Member

    There's no functionality for the RM yet. The language data is directly stored for each node and can be accessed by anyone who fetches the nodes, so it is fairly easy to build on it. If other addon developers create own node types, only minor ajustments are necessary to support the language filtering. If the addon is available for free, I can also do the Integration
     
  5. katsulynx

    katsulynx Well-Known Member

    I always forget to change that when copying the layout :mad:
     
    JustinHawk likes this.
  6. Alfa1

    Alfa1 Well-Known Member

    Do you have a demo board? It's not clear how this works for the reader.
    Does this affect the language metadata and url routes?
     
  7. katsulynx

    katsulynx Well-Known Member

    Nope

    And nope

    You just select a bunch of languages for a node and for the rest of languages, the node is hidden. That's it, basically.
     
  8. Alfa1

    Alfa1 Well-Known Member

    Do you mean that if the reader has a language selected for the UI then the nodes in other languages are hidden?
     
  9. katsulynx

    katsulynx Well-Known Member

    Yes, unless he opts in more in his preferences independently from his UI-language.
     
  10. Alfa1

    Alfa1 Well-Known Member

    Is there a setting for this in the user preferences or on the front end? Could you add a screenshot?
     
  11. katsulynx

    katsulynx Well-Known Member

    There are screenshots of every visible aspect on the overview page. You might also just try out the mod, it doesn't cost anything after all.
     
  12. rafass

    rafass Well-Known Member

    Hello katsulynx.
    I can not install it. is a fresh installation and I got this error:
    PHP:
    Server Error
    Undefined variable
    _tables
    XenForo_Application
    ::handlePhpError() in KL/LanguageForums/Install.php at line 51
    KL_LanguageForums_Install
    ::install()
    call_user_func() in XenForo/Model/AddOn.php at line 215
    XenForo_Model_AddOn
    ->installAddOnXml() in XenForo/Model/AddOn.php at line 169
    XenForo_Model_AddOn
    ->installAddOnXmlFromFile() in XenForo/ControllerAdmin/AddOn.php at line 188
    XenForo_ControllerAdmin_AddOn
    ->actionInstall() in XenForo/FrontController.php at line 351
    XenForo_FrontController
    ->dispatch() in XenForo/FrontController.php at line 134
    XenForo_FrontController
    ->run() in /home/sur/public_html/admin.php at line 13
    PHP:
    #0 /home/sur/public_html/library/KL/LanguageForums/Install.php(51): XenForo_Application::handlePhpError(8, 'Undefined varia...', '/home/mydomain/publi...', 51, Array)
    #1 [internal function]: KL_LanguageForums_Install::install(false, Array, Object(SimpleXMLElement))
    #2 /home/xxx/public_html/library/XenForo/Model/AddOn.php(215): call_user_func(Array, false, Array, Object(SimpleXMLElement))
    #3 /home/xxx/public_html/library/XenForo/Model/AddOn.php(169): XenForo_Model_AddOn->installAddOnXml(Object(SimpleXMLElement), false)
    #4 /home/xxx/public_html/library/XenForo/ControllerAdmin/AddOn.php(188): XenForo_Model_AddOn->installAddOnXmlFromFile('/tmp/phpbT0D1I')
    #5 /home/xxx/public_html/library/XenForo/FrontController.php(351): XenForo_ControllerAdmin_AddOn->actionInstall()
    #6 /home/xxx/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #7 /home/xxx/public_html/admin.php(13): XenForo_FrontController->run()
    #8 {main}
    Request State
    array(3) {
      [
    "url"] => string(39"http://xxx.xxx/admin.php?add-ons/install"
      
    ["_GET"] => array(1) {
        [
    "add-ons/install"] => string(0""
      
    }
      [
    "_POST"] => array(3) {
        [
    "server_file"] => string(0""
        
    ["_xfConfirm"] => string(1"1"
        
    ["_xfToken"] => string(8"********"
      
    }
    }
     
    katsulynx likes this.
  13. katsulynx

    katsulynx Well-Known Member

    rafass likes this.
  14. katsulynx

    katsulynx Well-Known Member

  15. Wasserlasser

    Wasserlasser Active Member

    Very interesting. Has anyone tried this and has a demo running?
     
  16. RhysR

    RhysR Member

    I have tried it, but there seems to be a bug preventing you from creating new language specific nodes (I already reported it last Saturday). Hopefully the problems will be resolved soon. This is a mod that really should be part of the XenForo core feature set.
     
  17. Wasserlasser

    Wasserlasser Active Member

    Seems to be not moving forward. Sad as this was something I was looking forward to.
     
  18. katsulynx

    katsulynx Well-Known Member

    RhysR likes this.
  19. Wasserlasser

    Wasserlasser Active Member

    Do you have an estimate on when this is leaving the Beta stage?
     
  20. katsulynx

    katsulynx Well-Known Member

    As soon as I find the time to implement all features listed on the front page. Beside that the addon is stable now though I guess, as there are no open bug reports.
     
    Wasserlasser likes this.

Share This Page