• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Fixed Kindle Fire / Silk Browser - Missing On-Screen Keyboard in Replies

Alien

Well-known member
#1
Reported by one of our members...

In the profile status/message entry field, the on screen keyboard appears and allows me to post an entry. However, tapping on the reply field in a thread does not produce the on-screen keyboard.
This was tested on multiple Fire's with the same results (even on XenForo.com), using v.6.1, 6.2 and the current v.6.2.1.

Can anyone else reproduce?
 

Mike

XenForo developer
Staff member
#3
It--like most mobile browsers--doesn't handle contenteditable well. Do you know what the user agent is? We can disable the RTE for it.
 

SneakyDave

Well-known member
#4
This is what I see in my access log. I have the " Accelerated" option in silk turned off, and it works a little better.

1.2.3.4 - - [05/Jan/2012:15:41:10 -0600] "GET /community/css.php?css=xenforo,form,public&style=4&dir=LTR&d=1325796898 HTTP/1.1" 200 19723 "http://blahblahblah.com/community/" "Mozilla/5.0 (Linux; U; Android 2.3.4; en-us; Silk/1.1.0-84) AppleWebKit/533.1 (KHTML, like Gecko) Version/4.0 Mobile Safari/533.1 Silk-Accelerated=false"
 

SneakyDave

Well-known member
#6
I thought it looked weird too, but I double checked. whatsmyuseragent.com says

Mozilla/5.0 (Linux; U; Android 2.3.4; en-us; Silk/1.1.0-84) AppleWebKit/533.1 (KHTML, like Gecko) Version/4.0 Mobile Safari/533.1 Silk-Accelerated=false
 

Mike

XenForo developer
Staff member
#7
Well, that's the same thing. I've tested it against our code and it matches the "mobile" type, which automatically disables the rich text editor. What are you seeing in the editor area?
 

SneakyDave

Well-known member
#8
Right now, I'm seeing the bare bones editor. Just the box and no rich text icons. In my original post up above, it was showing the rich text editor. I think I fixed it by turning off the "accellerated web browsing" in Silk, which uses some goofy Amazon cloud cache to speed things up I think.
 

Alien

Well-known member
#10
Here is what I got from two test cases experiencing the issue (One Fire, one HTC Evo 4g, Sprint):

1) Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_3; en-us; Silk/1.1.0-84) AppleWebKit/533.16 (KHTML, like Gecko) Version/5.0 Safari/533.16 Silk-Accelerated=true

(Tried disabling Accelerated, but did not fix anything)

2) Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_3; en-us) AppleWebKit/533.16 (KHTML, like Gecko) Version/5.0 Safari/533.16
 

Mike

XenForo developer
Staff member
#11
We can probably detect Silk in the first one, but otherwise that's a desktop user agent.

The second one is entirely a desktop user agent -- so unfortunately, there's not much we can do. I believe that I saw this once before and it was in a desktop masking mode.

(The problem is that the browsers actually support the RTE, but they don't know how to bring up the keyboard, so feature detection doesn't even work.)
 

Alien

Well-known member
#12
Follow-ups:

Kindle Fire

Test Case 1 said:
I'm certain I had previously tested all three view settings available to me (Automatic/Desktop/Mobile) but all this talk about the options prompted me to play with those settings again. My Fire was on Desktop view so I switched to Mobile and the keyboard appeared everywhere it was to be expected.

So this is where I stand (and if this is working as designed I'm sorry for even mentioning any this in the first place):

Desktop View Keyboard:
*Shoutbox (Add-on)
*Profile

Mobile View Keyboard:
*Shoutbox (Add-on)
*Profile
*Private Message
*Threads
HTC Evo 4g/Sprint

Test Case 2 said:
Yes desktop masking mode is correct, I hate the way mobile optimized pages look so I have it set to open like a pc. Didn't even think of that. Thanks
Test Case 2 said:
I stumbled across this by accident earlier today. I use the Swype keyboard on my phone. It did not come with the phone when I got it . Anyways, I had switched to stock keyboard for something earlier today and didn't remember to switch it back to Swype. Upon going to the forums, I noticed that RTE was gone by default. I know I didn't switch off PC masking and I know I didn't disable RTE in the WTF settings, So I was about to post saying that it was doing what it was supposed to do. Then I saw the default keyboard. Wondered if that was it and bingo RTE problem returned upon changing my default to Swype.

"TL;DR"
RTE is gone like it should be with stock keyboard and PC masking enabled
RTE problem occurs when I use Swype as my default.
Hope this helps...
 

a legacy reborn

Well-known member
#13
I am replying to this thread via my kindle and it is functioning normally.


Edit from PC: Ok, the issue only occurs when using desktop browing as the RTE appears but when using mobile it works fine. Browser Issue?
 

Mike

XenForo developer
Staff member
#14
I've added detection with "Silk-Accelerated" so that it's considered a mobile browser.

I don't see how Swype would change the user agent to show as a desktop browser, so that report is particularly weird. If we can get his user agent when it occurs (http://whatsmyuseragent.com/), then we can handle that. However, I'd do that in a separate bug report as this is related to Silk specifically.