1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed iPhone doesn't like the navigation

Discussion in 'Resolved Bug Reports' started by Shamil, Jul 31, 2010.

  1. Shamil

    Shamil Well-Known Member

    Maybe the iPhone is having more issues than I though but it doesn't like the navbar:


    But also, the WYSIWYG editor doesn't load at all.
  2. Floris

    Floris Guest

    It does, but since you have no mouse, you can not "hover"; ergo, only click (touch).
    This is an issue not limited to iPhone, until some sort of delay.state is introduced in webkit.
  3. Shamil

    Shamil Well-Known Member

    Sorry, I couldn't post the image from the phone, TinyMCE isn't loading.

    The links are misaligned.
  4. Floris

    Floris Guest

    Ah, that's something different, didn't realize you actually meant misaligned links :)
  5. Shamil

    Shamil Well-Known Member

    No worries - need to find out why TinyMCE isn't loading as well :/
  6. Floris

    Floris Guest

    It probably isn't recognized as modern browser, or fully Safari, so it falls back to 'working version', for say IE6, etc.
    I remember during the internal demo that it was mentioned they haven't had time yet to dive fully into the mobile part of things.
  7. Shamil

    Shamil Well-Known Member

    TinyMCE does have iPhone/iPad support, since 3.2.4. (r.isIDevice=/(iPad|iPhone)/.test(f)) I know there were a few issue with WebKit, so this might be contributary. We're out by 0.0.2 versions of TinyMCE.
  8. Enigma

    Enigma Well-Known Member

    It would probably also help the devs if you post the full user agent for your iPhone.
  9. Peggy

    Peggy Well-Known Member

    I'm having issues with xF on my iPhone as well concerning navigation in addition to image rendering. Odd stuff.
  10. DarkGizmo

    DarkGizmo Active Member

    Howabout an official Xenforo iPhone app like IPS has? That'd be ideal :D
  11. Peggy

    Peggy Well-Known Member

    It would be, and has been mentioned to the devs.
  12. Floren

    Floren Well-Known Member

    Works perfect for me in WebOS (Palm Pre).
  13. Booth

    Booth Well-Known Member

    TinyMCE has never worked for me on Safari either on Mac OSX or my iPad. And on iPad the links at the top are misaligned too.

    Other than those problems, I've got to say the minimal design of xenForo and the practicality of using the iPad really does work well. Other forums on the iPad don't even come close.
  14. Facepalmx2

    Facepalmx2 Active Member

    Same issue for myself.

    User Agent: Mozilla/5.0 (iPhone; I; CPU iPhone OS 3_1_2 like Mac OS X; en-us) AppleWebKit/528.18 (KHTML, like Gecko) Version/4.0 Mobile/7D11 Safari/528.16)
  15. goyo

    goyo Member

    Works well on Android...
  16. RSZ

    RSZ Member

    I couldnt even log on using my iPhone, The login and signup are unlickable.
  17. Peggy

    Peggy Well-Known Member

    the login and signup on my iphone are fine.

Share This Page