• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Browser issue  iPhone 4: Editor toolbar missing (quick reply and full editor)

CTXMedia

Formerly CyclingTribe
#1
It's only happened in the last week or so, but I noticed today that I don't have the editor toolbar on my iPhone 4 any more:

IMG_0141.png
IMG_0142.png
I haven't tried rebooting my iPhone, but I wondered if there had been any template / site updates recently that might have caused this?

Cheers,
Shaun :D
 

CTXMedia

Formerly CyclingTribe
#2
I updated to iOS 4.2 last night and rebooted as part of the process. No change on xF, still no editor toolbar.

Cheers,
Shaun :D
 

Brogan

XenForo moderator
Staff member
#3
It doesn't look to me as if the WYSIWYG editor toolbar is missing, from those screenshots it appears that the BB Code editor is enabled by default with no option to select the WYSIWYG editor.
 

EQnoble

Well-known member
#5
The iPhone has never supported the WYSIWYG editor.
Yeah it's something internal in the iPhone itself I believe ( I may be wrong ) as I just was playing with a browser that lets me render pages as different browsers, though everything else looks different slightly the WYSIWYG editor still does not open the OSK. Is this a TinyMCE thing? ,or just the way the iPhone handles it? Kind of interested to know if there is a obvious reason why because it is not very blatant to me.
 

EQnoble

Well-known member
#7
Well I can make it display which if you look at Geeks image it doesn't display the editor...i can interact with mine and such...as this image shows.... which to me is very odd.
photo.PNG
 

EQnoble

Well-known member
#9
Yes I am ... and rendering pages right now as if I was on a mac computer.

some more interesting behavior ...
photo(2).PNG
I will now try to post from the phone ...using this and embed a test img
 

EQnoble

Well-known member
#11
The above post was done from the iphone....

here's some shots...

photo(3).PNG photo(5).PNG photo(4).PNG

and as you see from the previous post it was successful... lol that's cool :) But I still have no clue why that behavior presents.
 

Mike

XenForo developer
Staff member
#12
...except you can't actually type into the box can you? :) The issue is that mobile WebKit doesn't trigger the keyboard in a contenteditable area.
 

EQnoble

Well-known member
#13
...except you can't actually type into the box can you? :) The issue is that mobile WebKit doesn't trigger the keyboard in a contenteditable area.
Yep that's the one thing I couldn't do but who needs a text editor to do that anyways :p

So my next question is , will this be something that can worked around somehow or is this not possible at without a completely different web-browser or a XFmobile app for opening xF based sites?
 

Mike

XenForo developer
Staff member
#14
The limitation is basically entirely on the phone. I don't even know if an app could reasonably workaround it.