1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Internal Error Notice

Discussion in 'Troubleshooting and Problems' started by wickedstangs, Aug 8, 2013.

  1. wickedstangs

    wickedstangs Well-Known Member

    I keep getting this error and nothing really I can see is wrong. Also, no server notices..
    internal error.JPG
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Have you checked the server error logs?

    That is the only way to see what is happening.
     
  3. wickedstangs

    wickedstangs Well-Known Member

    There is none..
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Is logging switched off?
    Without some sort of log as to what is happening or why, this will be impossible to troubleshoot.

    When is the error triggered?
     
  5. borbole

    borbole Well-Known Member

    Where do you get that error? Did you do any modification to the forum prior to that happening?

    Also can you check the server error log at the cpanel of your host and see if anything is logged there?
     
  6. Jeremy

    Jeremy XenForo Moderator Staff Member

    That type of error won't be logged into XenForo's ACP but the actual server. Did you check there versus the ACP?
     
  7. wickedstangs

    wickedstangs Well-Known Member

    I get that error, when replying to a thread and typing and taking my time:) I useto see message saved now I think I don't..
     
  8. borbole

    borbole Well-Known Member

    Can you try to disable all mods so to rule out one of them being the cause of the issue? Also, have a look at the server error log at your cpanel if anything related to this has been logged there. It would help us troubleshoot the issue.
     
  9. wickedstangs

    wickedstangs Well-Known Member

    can't get to my cpanel from military computers:( will disable mods and try again..
     
  10. kprojects

    kprojects Well-Known Member

    Can you ssh in from where you are?
     
  11. wickedstangs

    wickedstangs Well-Known Member

    @borbole @Brogan here are the results..

    Code:
    These are the last few apache requests from wickedstangs.com to return error 500:
    ===
    root@host [~]# awk '($9 ~ /500/){print $0}' /usr/local/apache/domlogs/wickedstangs.com | tail
    173.213.98.65 - - [08/Aug/2013:03:55:57 -0400] "GET /community/login/login HTTP/1.0" 500 5777 "http://www.wickedstangs.com/community/login/login" "Mozilla/5.0 (Windows NT 6.1; rv:5.0) Gecko/20100101 Firefox/5.02"
    173.199.120.43 - - [08/Aug/2013:11:22:24 -0400] "GET /community/threads/sd-wicked-wednesday-goodys-deli-sushi-grill.20010/poll/vote HTTP/1.1" 500 5902 "-" "Mozilla/5.0 (compatible; AhrefsBot/4.0; +http://ahrefs.com/robot/)"
    128.49.161.43 - - [08/Aug/2013:11:52:59 -0400] "POST /community/threads/discovery-tv-street-outlaws-from-okc.21049/save-draft HTTP/1.1" 500 546 "http://www.wickedstangs.com/community/" "Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0)"
    128.49.161.43 - - [08/Aug/2013:11:54:59 -0400] "POST /community/threads/discovery-tv-street-outlaws-from-okc.21049/save-draft HTTP/1.1" 500 546 "http://www.wickedstangs.com/community/" "Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0)"
    128.49.161.43 - - [08/Aug/2013:11:55:33 -0400] "POST /community/threads/discovery-tv-street-outlaws-from-okc.21049/add-reply HTTP/1.1" 500 546 "http://www.wickedstangs.com/community/" "Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0)"
    128.49.161.43 - - [08/Aug/2013:12:03:36 -0400] "POST /community/threads/wicked-stangs-chapter-presidents-post-here.19514/save-draft HTTP/1.1" 500 546 "http://www.wickedstangs.com/community/" "Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0)"
    128.49.161.43 - - [08/Aug/2013:12:19:16 -0400] "POST /community/posts/211102/like HTTP/1.1" 500 546 "http://www.wickedstangs.com/community/" "Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0)"
    75.83.197.236 - - [08/Aug/2013:12:40:55 -0400] "GET /community/login/login HTTP/1.0" 500 30662 "http://www.wickedstangs.com/community/login/login" "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.1; WOW64; Trident/6.0)"
    109.194.230.138 - - [08/Aug/2013:13:48:39 -0400] "GET /community/index.php?login/login HTTP/1.0" 500 17421 "http://www.wickedstangs.com/community/index.php?login/login" "Opera/9.80 (Windows NT 5.1; U; ru) Presto/2.10.289 Version/12.01"
    208.177.76.26 - - [08/Aug/2013:14:20:35 -0400] "GET /community/index.php?login/login HTTP/1.0" 500 17410 "http://www.wickedstangs.com/community/index.php?login/login" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/534.57.2 (KHTML, like Gecko) Version/5.1.7 Safari/534.57.2"
    ===
    
    These errors were logged in the Apache error log for the IP addresses whose apache requests returned error 500:
    ===
    root@host [~]# for each in $(awk '($9 ~ /500/){print $1}' /usr/local/apache/domlogs/wickedstangs.com | tail | sort | uniq); do grep $each /usr/local/apache/logs/error_log; done | awk '($6 ~ /error/){print $0}' | grep -v "File does not exist:"
    [Wed Aug 07 16:07:07 2013] [error] [client 128.49.161.43] Handler for (null) returned invalid result code 70007, referer: http://www.wickedstangs.com/community/
    [Thu Aug 08 11:53:19 2013] [error] [client 128.49.161.43] Handler for (null) returned invalid result code 70007, referer: http://www.wickedstangs.com/community/
    [Thu Aug 08 11:55:19 2013] [error] [client 128.49.161.43] Handler for (null) returned invalid result code 70007, referer: http://www.wickedstangs.com/community/
    [Thu Aug 08 11:55:53 2013] [error] [client 128.49.161.43] Handler for (null) returned invalid result code 70007, referer: http://www.wickedstangs.com/community/
    [Thu Aug 08 12:03:56 2013] [error] [client 128.49.161.43] Handler for (null) returned invalid result code 70007, referer: http://www.wickedstangs.com/community/
    [Thu Aug 08 12:19:36 2013] [error] [client 128.49.161.43] Handler for (null) returned invalid result code 70007, referer: http://www.wickedstangs.com/community/
    ===
    
    These are the most recent apache error log entries over all, not counting file not found errors:
    ===
    root@host [~]# grep -v "File does not exist:" /usr/local/apache/logs/error_log | tail
    [Thu Aug 08 11:00:53 2013] [notice] Apache/2.2.25 (Unix) mod_ssl/2.2.25 OpenSSL/1.0.0-fips mod_bwlimited/1.4 configured -- resuming normal operations
    [Thu Aug 08 11:53:19 2013] [error] [client 128.49.161.43] Handler for (null) returned invalid result code 70007, referer: http://www.wickedstangs.com/community/
    [Thu Aug 08 11:55:19 2013] [error] [client 128.49.161.43] Handler for (null) returned invalid result code 70007, referer: http://www.wickedstangs.com/community/
    [Thu Aug 08 11:55:53 2013] [error] [client 128.49.161.43] Handler for (null) returned invalid result code 70007, referer: http://www.wickedstangs.com/community/
    [Thu Aug 08 12:03:56 2013] [error] [client 128.49.161.43] Handler for (null) returned invalid result code 70007, referer: http://www.wickedstangs.com/community/
    [Thu Aug 08 12:05:00 2013] [error] [client 31.184.244.22] Handler for (null) returned invalid result code 70014
    [Thu Aug 08 12:19:36 2013] [error] [client 128.49.161.43] Handler for (null) returned invalid result code 70007, referer: http://www.wickedstangs.com/community/
    [Thu Aug 08 13:29:21 2013] [error] [client 114.251.150.133] Invalid method in request \x80g\x01\x03\x01
    [Thu Aug 08 14:21:00 2013] [notice] Graceful restart requested, doing restart
    [Thu Aug 08 14:21:01 2013] [notice] Apache/2.2.25 (Unix) mod_ssl/2.2.25 OpenSSL/1.0.0-fips mod_bwlimited/1.4 configured -- resuming normal operations
    ===
    
    If you can give me the exact url which is giving you the Internal Server Error, I can do more specific troubleshooting to see if there might be other relevant log entries or server settings I could help you fix.
    
     
  12. wickedstangs

    wickedstangs Well-Known Member

    This is the ip I am on 128.49.161.43

    128.49.161.43 - - [08/Aug/2013:11:52:59 -0400] "POST /community/threads/discovery-tv-street-outlaws-from-okc.21049/save-draft HTTP/1.1" 500 546 "http://www.wickedstangs.com/community/" "Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0)"
    128.49.161.43 - - [08/Aug/2013:11:54:59 -0400] "POST /community/threads/discovery-tv-street-outlaws-from-okc.21049/save-draft HTTP/1.1" 500 546 "http://www.wickedstangs.com/community/" "Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0)"
    128.49.161.43 - - [08/Aug/2013:11:55:33 -0400] "POST /community/threads/discovery-tv-street-outlaws-from-okc.21049/add-reply HTTP/1.1" 500 546 "http://www.wickedstangs.com/community/" "Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0)"
    128.49.161.43 - - [08/Aug/2013:12:03:36 -0400] "POST /community/threads/wicked-stangs-chapter-presidents-post-here.19514/save-draft HTTP/1.1" 500 546 "http://www.wickedstangs.com/community/" "Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0)"
     
  13. The Forum Heroes

    The Forum Heroes Well-Known Member

    Try tailing the error_log and see if any errors when you go to the site pop up.
     
  14. praj

    praj Member

    @wickedstangs I faced a similar issue. I could not edit the first post of any thread, with the same error being thrown up as your screenshot. Turned out it was mod_sec.

    More often than not, it's usually the mod_security rules. I have my own dedicated box, so I was able to get into WHM and edit the mod_security rules. Maybe you can have your host look into your mod_security rules.
     
    wickedstangs likes this.
  15. wickedstangs

    wickedstangs Well-Known Member

    I have WHM were is the mod_security rules located?
     
  16. praj

    praj Member

    Bottom Left. The last link for me is Mod Security. It's under "Plugins".

    [​IMG]
     
  17. The Forum Heroes

    The Forum Heroes Well-Known Member

    Yeah, sounds like Mod_Security for sure.
     
  18. wickedstangs

    wickedstangs Well-Known Member

    This is my Mod Security what do I do in here...?
    modsec.JPG
     
  19. The Forum Heroes

    The Forum Heroes Well-Known Member

    Edit your config to white list the triggered rule expression.
     
  20. wickedstangs

    wickedstangs Well-Known Member

    ????
     

Share This Page