XF 1.1 Importing phpBB problems

Mike

XenForo developer
Staff member
Any idea why it isn't importing anything? Already imported SMF to PHPBB3 successful but not Xenforo...
Are you sure you pointed it at a database with data in it? Those numbers would indicate that it was an empty DB (or that the table prefix was pointing to empty data).
 

Dismal Shadow

Active member
But it's pointing to the correct database and correct prefix with data in it. This is also happening on my localhost.
 

Dismal Shadow

Active member
Ok looks like I input the wrong database table, so it imports everything well expect for attachments where I got:

Code:
Server Error
 
copy() [function.copy]: The first argument to copy() function cannot be a directory
 
XenForo_Application::handlePhpError() in XenForo/Importer/PhpBb3.php at line 2074
XenForo_Importer_PhpBb3->stepAttachments() in XenForo/Importer/Abstract.php at line 77
XenForo_Importer_Abstract->runStep() in XenForo/ControllerAdmin/Import.php at line 180
XenForo_ControllerAdmin_Import->_runStep() in XenForo/ControllerAdmin/Import.php at line 232
XenForo_ControllerAdmin_Import->_startStep() in XenForo/ControllerAdmin/Import.php at line 175
XenForo_ControllerAdmin_Import->actionStartStep() in XenForo/FrontController.php at line 310
XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
XenForo_FrontController->run() in /public_html/community/admin.php at line 13
 

Mike

XenForo developer
Staff member
Moved these out to a new thread so it makes more sense.

It sounds like your attachment entry doesn't actually have a physical_filename set in the table - I don't think you can import them. (I'm not sure if phpBB would even see them.)
 

Hambil

Member
They are stored by id, I believe. If I recall correctly the attachments will actually be saved to an attachment directory as 1.jpg (or whatever) 2.jpg, 3.jpg, etc.
 

Brogan

XenForo moderator
Staff member
phpBB attachments are stored with random file names and no extension, such as 2_0e5439b9d39f6e8874fd6352108e6b4e, with the corresponding thumbnails as thumb_2_0e5439b9d39f6e8874fd6352108e6b4e.
 

Brogan

XenForo moderator
Staff member
The attachments table does indeed contain the real file name and physical file name - I just checked my installation.

The physical file however is just stored using the physical file name.
 
Top