• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Imported from vb 3.8.7 - users cannot see forums

cynthetiq

Active member
#1
the migrated super moderators cannot see old forums. They see only the new ones. Everyone has the General Permissions set to NO.

I had to go in and reset them all as explicit users. The supermoderators group seemed fine, there's another super moderator group imported from VB.

I'm just wondering if this is supposed to act this way or not and what's a fast global fix?
 

Jake Bunce

XenForo moderator
Staff member
#2
Probably this:

http://xenforo.com/community/threads/problem-with-import-of-vb-3-8-5.14572/#post-190853

Basically you need to redo your private forum permissions the XenForo way:

http://xenforo.com/community/threads/understanding-permissions.5830/

Creating a private forum

Because of the way Revoke works in xenForo you shouldn't use it to restrict a private forum. Instead you should use a special feature in xenForo called Private node. You will see the Private node checkbox when editing the permissions for a specific node. This basically inverts the permissions so that you can specify Allowed groups instead of Revoked groups. This is actually better for group management if you add more groups later.

Admin CP -> Users -> Node Permissions -> [select a forum] -> Private node
 

cynthetiq

Active member
#3
I got that it would be problematic with private forums staff only forums, but the regular forums that were available to everyone and had little customized permissions. The basic ones that were from VB weren't visible at all.