1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Import from VBGallery

Discussion in 'Media Gallery Support' started by Arno Nühm, Jan 23, 2015.

  1. Arno Nühm

    Arno Nühm Active Member

    Hello from Germany,

    I just installed the XFMG in my XF test forum and tried to import the images from my existing VBulletin forum on the same server.

    The ppgal_images table has about 23.000 images. The media import took nearly 2 hours, BUT then it showed "0 images". The xengallery_media table also has 0 entries.

    It took so long and there are NO images imported at all.

    What happened? What went wrong?
     
  2. Chris D

    Chris D XenForo Developer Staff Member

    Common causes of this would be not specifying the correct import log from your original VB import. The importer needs this so it can map the images in your Gallery to the users you imported into XF.

    When you did the import from VB to XF, at the end you would have been asked to create an archived_import_log table.

    Whatever you name specified for that table, you needed to specify when setting up the VBGallery to XFMG import.

    Another common cause would be it not being able to find the actual files for the images in VBGallery.

    Have another go at setting up the import, and running it. Have your actual site open in another tab, you should be able to see the images being imported as the importer runs through the Import Media step. If nothing is being populated here, it's not working then you can cancel and try again (rather than waiting 2 hours to find out if it worked or not).
     
    Arno Nühm likes this.
  3. Arno Nühm

    Arno Nühm Active Member

    Thanks, Chris.

    I just uninstalled XFMG and re-installed it. Now I am importing again. This time I noticed that I have to enter the path to the files folder ([...]/galerie/files), not just to the gallery folder. I guess that was my fault. If not I will reply here again :)
     
    Chris D likes this.
  4. Bonsai Coder

    Bonsai Coder Active Member

    LOL ok... so I have no idea where my import log table is, nor even any idea if I created one(?) Can you actually import from vBulletin and NOT create a table? Do I have to reinstall xenForo from SCRATCH if one was not created?
     
  5. Chris D

    Chris D XenForo Developer Staff Member

    Do you get the option to create one if you go to Admin CP > Tools > Import External Data?

    Do you have a table named archived_import_log?

    Do you have a table that isn't prefixed with xf_ in your database?

    Are there any contents in your xf_import_log table?
     
  6. Bonsai Coder

    Bonsai Coder Active Member

    Thanks for the support!

    When I first entered Admin CP > Tools > Import External Data, it gave me the option to create the file. But when I tried to create it, I got the following error message:

    It is not possible to create the table 'archived_import_log' due to the following error: Mysqli statement execute error : Table 'archived_import_log' already exists.

    So I assume it is already there... I enter "archived_import_log" in the field, and now I am getting rejected with the error message:

    The source database connection details are not correct: Access denied for user 'mydatabasename'@'localhost' (using password: YES)

    I am on the same server, and localhost went off without a hitch for my vBulletin data import, however for some reason I cannot access the PhotoPost database. I know the account details are correct because I have the PhotoPost Admin menu open right next to me and am cutting and pasting the values directly in.

    My question now is... I am importing from a different user (ie cPanel account) on the server than where the PhotoPost DB is located. Would that be an issue?
     
  7. Bonsai Coder

    Bonsai Coder Active Member

    I think I figured it out...

    I exported a copy of the PhotoPost DB over to this user, and created a new DB user account, etc, and it appears that everything worked fine.
     
  8. Bonsai Coder

    Bonsai Coder Active Member

    Well it did NOT work fine. All users, albums and categories were imported... but no media was. Do you think moving the database somehow messed with the path to the photopost data directory and the importer didn't know where to find the data?
     
  9. Bonsai Coder

    Bonsai Coder Active Member

    So I guess you can't import from a PhotoPost Gallery unless your xenForo install is on the same server account?
     
  10. Chris D

    Chris D XenForo Developer Staff Member

    What version of XFMG are you importing into?
     
  11. Bonsai Coder

    Bonsai Coder Active Member

    1.0.2
     
  12. Bonsai Coder

    Bonsai Coder Active Member

    Well I unstalled XFMG and reinstalled from scratch.

    I imported my photopost gallery DB into my current account (that holds my xenForo install). I even downloaded my photopost datafiles to my desktop and then uploaded them into my current server account so I now have a path on this server account to the data files.

    I have confirmed the database name, database user name, and database user password in cPanel.

    I have confirmed the data files location in Filezilla.

    Now when I enter THIS EXACT DATA into the importer I get the following error message:

    Error

    • The table prefix or database name is not correct.
    • The specified file location does not exist.
    When I leave the data file location blank, I get:

    Error

    • The table prefix or database name is not correct.
    I have tried leaving the Table Prefix field blank, or entering the value "pp_" (which is my database table prefix) and it does not change the error messages above.

    When I point the installer at the current (working) PhotoPost database on my other cPanel account I get:

    Error
    The source database connection details are not correct: Access denied for user 'bonsainu_photogal'@'localhost' (using password: YES)
     
  13. Bonsai Coder

    Bonsai Coder Active Member

    Is it possible that the importer is comparing the values I entered manually to the values in the PhotoPost configuration? Or something equally wacky? Because the name of my imported DB will not be the same as the name of the DB in my PhotoPost configuration... though all the data will be identical.
     

Share This Page