• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Import fails with no error

#1
I am having a problem trying to import from VB.
The XF importer hangs with no real information while transporting Threads and Posts:
All it shows is:
A server error occurred. Please try again later.

There is no error in the Server Log or elsewhere to look for. (We have something like 900 k posts and the upload hangs somewhere at 500k).

Any idea how to locate the problem.
 
#5
Thx Steven,
At least some one tried to help.
I am trying to remove some posts (the sequent posts from the last one) and will see if that helps.

The real problem is that the error: "Server error occurred" provides no real information and there is nothing to debug or "correct".
Wish there was some more information in the process. For sure it is not a problem with server, or memory restrictions. Blaming it on the charsets or similar problems that halt the mysq_queries
 

Mike

XenForo developer
Staff member
#6
When people refer to the server error logs, in this case they're referring to that section in "tools" in the admin CP, rather than a Apache-level log.

There have been reports of things not going into that log, though I haven't been able to reproduce that personally. As an alternative, you can enable debug mode by adding this to config.php:

$config['debug'] = true;

You'll get a specific error then.
 
#8
Any idea how to locate the post that is creating the problem? Tried removing the sequent post with no luck .


Mysqli statement execute error : Incorrect string value: '\xF4\x80\x82\xBC V...' for column 'message' at row 1

1. Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 292
2. Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 468
3. Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 546
4. Zend_Db_Adapter_Abstract->insert() in XenForo/DataWriter.php at line 1490
5. XenForo_DataWriter->_insert() in XenForo/DataWriter.php at line 1479
6. XenForo_DataWriter->_save() in XenForo/DataWriter.php at line 1287
7. XenForo_DataWriter->save() in XenForo/Model/Import.php at line 292
8. XenForo_Model_Import->_importData() in XenForo/Model/Import.php at line 809
9. XenForo_Model_Import->importPost() in XenForo/Importer/vBulletin.php at line 1823
10. XenForo_Importer_vBulletin->stepThreads() in XenForo/Importer/Abstract.php at line 77
11. XenForo_Importer_Abstract->runStep() in XenForo/ControllerAdmin/Import.php at line 161
12. XenForo_ControllerAdmin_Import->_runStep() in XenForo/ControllerAdmin/Import.php at line 105
13. XenForo_ControllerAdmin_Import->actionImport() in XenForo/FrontController.php at line 303
14. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
15. XenForo_FrontController->run() in /var/www/vhosts/mydomain.com/httpdocs/xf/admin.php at line 13
 

Brogan

XenForo moderator
Staff member
#9
Are you able to access the post and thread tables in the XF database?
The last post/thread in those tables might give a clue as to why it is halting at that point.