• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 Image path

Morgain

Well-known member
#1
I think the problem I have is with the image path.

I just started my active install with 1.1
copying over various bits of design I worked out on a 1.0 test install.
NONE of my images using image_path show up.
But they don't show hard coding the URL either!

www.housemorgain.co.uk/circle

The image path setting is styles/ default
so uploading the image file to \styles\default --- I tried

Code:
<img src="@imagePath/candles2.png" />
(Should show beside ALL FORUMS top of sidebar on right.)

I tried this with the full URL
Code:
<img src="http://www.housemorgain.co.uk/circle/styles/default/candles2.png"" />
Also tried uploading image to \widgets as it was on my test install + full URL
Code:
<img src="http://www.housemorgain.co.uk/circle/styles/default/xenforo/widgets/candles2.png"" />
I tried on the old image path I used on the test install just in case I had misunderstood the different image path.
Code:
<img src="@imagePath/xenforo/widgets/candles2.png" />
Didn't work either.
 

Brogan

XenForo moderator
Staff member
#2
Where are you using that?

If on a Page then use a relative path such as styles/your-style-name/path/image.png
 

Morgain

Well-known member
#5
This is what it should look like top of sidebar​
menu-image.png

SETTING FOR IMAGE PATH:
Path to Images styles/default

UPLOADS:
The image candles2.png
has been uploaded to

circle/styles/default/
AND
circle/styles/default/xenforo/widgets/
(the 2nd location was my previous image path)

CODING:
In sidebar where it worked fine for my test install. I have tried:

Code:
 <img src="@imagePath/candles2.png" />
 
<img src="@imagePath/xenforo/widgets/candles2.png" />
 
<img src="http://www.housemorgain.co.uk/circle/styles/default/xenforo/widgets/candles2.png" />
 
<img src="http://www.housemorgain.co.uk/circle/styles/default/candles2.png" />