1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I am sick of tired..

Discussion in 'Troubleshooting and Problems' started by crazy, Apr 13, 2012.

  1. crazy

    crazy Member

    Sorry for the title but the thing is it is true. I am sick of tired from errors and my ultra very slow forum

    I am on a dedicated and I am alone (!)

    I did all the innodb tuning settings , I am using cache , I tried litespeed nothing changed.

    Please look the picture

    [​IMG]
    [​IMG]

    Are you seeing the error times? in the same minute there are hundred errors and can u see the page size? 5290 thousand page error(!)

    105.796 thousand errors(!)

    I am really about the sell my forum because of this. Since I moved xenforo I cant get rid of this errors.

    All of my users are getting these things and they are telling me everyday hundred times. We put litespeed we tried everything but my forum is ultra slow.

    Can someone save me?
     
  2. Digital Doctor

    Digital Doctor Well-Known Member

    This is a server problem or xenforo setup problem. Bad import ?
    Your lack of details about your setup is truly depressing.
    It's like you don't want people to help.

    I hate to state the obvious but you are unlikely to speed things up unless you correct the errors.

    mysqli statement execute error incorrect key file for table [link]
    http://xenforo.com/community/threads/server-error.25393/
     
  3. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Error 28 means the hard drive or partition is full. In this case it appears to be the /tmp partition. This problem can also cause the other errors in your log. Your host or server person needs to check all partitions and allocate more space as needed. After that is done then you should use phpmyadmin to run a repair on your database.
     
    crazy, Shelley and Digital Doctor like this.
  4. Digital Doctor

    Digital Doctor Well-Known Member

  5. Digital Doctor

    Digital Doctor Well-Known Member

    http://xenforo.com/community/thread...error-got-error-28-from-storage-engine.13235/

     
  6. crazy

    crazy Member

    Thanks for answers. My /tmp is already empty. Just 38MB in it

    there is the picture

    [​IMG]
     
  7. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    It may not be full now, but it was full when that error happened.

    Screen shot 2012-04-12 at 7.09.15 PM.png
     
  8. crazy

    crazy Member

    It could be refreshed automatically I didnt do it

    Are u suggest me to make the tmp higher GB? or do u have other suggestions for fixing this issue?

    Thanks a lot
     
  9. Digital Doctor

    Digital Doctor Well-Known Member

    Are you getting those errors now that your /tmp is not full ?
     
  10. crazy

    crazy Member

    No,last error was 5 hours ago.

    PS: Now we did the /tmp 4GB.
     
  11. Digital Doctor

    Digital Doctor Well-Known Member

    I wonder what fills up the /tmp
     
    crazy likes this.
  12. crazy

    crazy Member

    Is that related with mysql? Should I empty some tables?
     
  13. Digital Doctor

    Digital Doctor Well-Known Member

    MySQL's use of /tmp seems to be the culprit in previous cases ... in one of my links above ... bambua seemed to have a prevention strategy.
     
  14. Floris

    Floris Guest

    That error has nothing to do with XenForo or MySQL really. Since error 28 is a system return error saying there was no ability to write away the data to disk due to disk partition being full. It would be handy if it came along with the hardware identifier of that partition though.
     
  15. crazy

    crazy Member

    Thanks for reply do u have a suggestion?

    My website is not opening since 1 .30 hour .Now we fixed it. Problem is My TMP is 4gb(we increased it yesterday) and 3.4 gb is already fulled.Now we are cleaning /tmp and website going normal. I dont know how my forum did that.
    and it is not a server problem other 2 mini websites are running well.

    Can someone give me a solution about /tmp?
     
  16. crazy

    crazy Member

    Sorry for flood,

    I have around 1 hundred of these errors today

    when I go to the error it gives me

    Hata Bilgisi
    Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : Incorrect key file for table '/tmp/#sql_6c62_15.MYI'; try to repair it - library/Zend/Db/Statement/Mysqli.php:214
    9minutes ago
    Stack Trace
    #0 /home/netbilgi/public_html/library/Zend/Db/Statement.php(297): Zend_Db_Statement_Mysqli->_execute(Array)
    #1 /home/netbilgi/public_html/library/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
    #2 /home/netbilgi/public_html/library/XenForo/Model.php(218): Zend_Db_Adapter_Abstract->query('?????SELECT thr...', Array, 2)
    #3 /home/netbilgi/public_html/library/XenForo/Model/Thread.php(371): XenForo_Model->fetchAllKeyed('?????SELECT thr...', 'thread_id')
    #4 /home/netbilgi/public_html/library/******AdvStats/Renderer.php(207): XenForo_Model_Thread->getThreads(Array, Array)
    #5 /home/netbilgi/public_html/library/******AdvStats/Renderer.php(269): ******AdvStats_Renderer::renderSectionThreadPrepare(Array, 'threads_recent')
    #6 /home/netbilgi/public_html/library/******AdvStats/Renderer.php(381): ******AdvStats_Renderer::renderSection(Array, Array)
    #7 /home/netbilgi/public_html/library/******AdvStats/Renderer.php(27): ******AdvStats_Renderer::_prepareSectionForWrapper('threads', 'threads_recent', 'threads-recent', Array, Object(XenForo_Template_Public))
    #8 /home/netbilgi/public_html/library/******AdvStats/Listener.php(66): ******AdvStats_Renderer::renderWrapper(Array, Array)
    #9 /home/netbilgi/public_html/library/XenForo/CodeEvent.php(54): ******AdvStats_Listener::template_post_render(Object(XenForo_Template_Public))
    #10 /home/netbilgi/public_html/library/XenForo/Template/Abstract.php(195): XenForo_CodeEvent::fire('PAGE_CONTAINER', '<!DOCTYPE html>...', Array, Object(XenForo_Template_Public))
    #11 /home/netbilgi/public_html/library/XenForo/Template/Public.php(110): XenForo_Template_Abstract->render(Array, Array)
    #12 /home/netbilgi/public_html/library/XenForo/ViewRenderer/HtmlPublic.php(135): XenForo_Template_Public->render('template_post_r...', Array)
    #13 /home/netbilgi/public_html/library/XenForo/FrontController.php(565): XenForo_ViewRenderer_HtmlPublic->renderContainer()
    #14 /home/netbilgi/public_html/library/XenForo/FrontController.php(156): XenForo_FrontController->renderView()
    #15 /home/netbilgi/public_html/index.php(13): XenForo_FrontController->run(Object(XenForo_Template_Public), Array)
    #16 {main}
     
  17. Brogan

    Brogan XenForo Moderator Staff Member

    Try disabling that add-on, whatever it is.

    If it's from the site I think it is, I would think twice about using an add-on from a site that uses nulled software.
     
  18. crazy

    crazy Member

    Sorry, are you saying that I am using nulled xenforo?

    Actually I am trying to disable but my admin panel is not opening it gives me same error. I will do that in 5 minutes when I can enter it

    Update: I disabled the addon ******advstats
     
  19. crazy

    crazy Member

    Sorry for the flood again,

    Here is my add-ons

    Automatic Mobile Style Switcher
    duythinht's Most Liked
    duythinht's Top Posters
    Easy ban users 1.0.1
    Sitemap for XenForo
    [xfr] User Albums
     
  20. Deebs

    Deebs Well-Known Member

    Can you get a copy of your my.cnf and post (make sure no passwords are in it).
     

Share This Page