• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 Huge topic page load very slowly

#1
We have a thread that has a huge first page and it takes a long time to load and it actually triggers an entry in our mysql long query logs, taking around 4 seconds to complete the query.

The affected thread *:
http://www.techspot.com/ community/topics/google-redirect-and-tdsskiller-wont-run.159317/

Might be related, our DB is running with every table as MyISAM, we haven't changed the tables to InnoDB because we are still testing new backup scripts that work efficiently with InnoDB.

* Removed link because I don't wan't crawlers opening that page or anyone abusing it.
 

Jake Bunce

XenForo moderator
Staff member
#2
Try enabling debug mode by adding this line to your library/config.php file:

Code:
$config['debug'] = 1;
That will display load stats and explain each query. That may help to know where the problem lies. Also check your server load by running "top" in the shell. Check standard stuff like free memory, swap, disk usage, cpu usage, heavy processes, etc.

Might be related, our DB is running with every table as MyISAM, we haven't changed the tables to InnoDB because we are still testing new backup scripts that work efficiently with InnoDB.
Your forum is sufficiently large and busy that you may be experiencing scaling issues with MyISAM. InnoDB scales much better.
 
#4
Thanks, our server administrator is working on migrating the backup script to mydumper.

And I'll post an update if we find the problem causing this excessive load.