1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

.htaccess problem

Discussion in 'XenForo Questions and Support' started by addaco, May 25, 2011.

  1. addaco

    addaco Member

    Hey

    I am trying to get 301 htaccess redirect to work at the same time with mod_rewrite full friendly url's. The problem is I am unsure how to make them work together so that www.example.com/community points to example.com/community.

    Code for the mod_rewrite full friendly urls:
    HTML:
    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #    SecFilterEngine Off
    #    SecFilterScanPOST Off
    #</IfModule>
    
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    
    <IfModule mod_rewrite.c>
        RewriteEngine On
    
        #    If you are having problems with the rewrite rules, remove the "#" from the
        #    line that begins "RewriteBase" below. You will also have to change the path
        #    of the rewrite to reflect the path to your XenForo installation.
        #RewriteBase /xenforo
    
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data|js|styles|install) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
    </IfModule>
    Code for 301 redirect
    HTML:
    RewriteEngine On
    Options +FollowSymLinks
    RewriteCond %{HTTP_HOST} ^www.prteamwork.com [NC]
    RewriteRule ^(.*)$ http://prteamwork.com/community/$1 [L,R=301]
    Many thanks and sorry for posting lots of code
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    I use this for removing www from all URLs, but in the root .htaccess, not the forum .htaccess:

    Code:
    RewriteCond %{HTTP_HOST} www.cliptheapex.com$
    RewriteRule ^(.*)$ http://cliptheapex.com/$1 [R=301,L]
     
  3. addaco

    addaco Member

    hmm
    I've tried that in the root and it redirects in the root but doesn't follow through down to /community
     
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    The www rules should go before the friendly rules, like so:

    Code:
    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #    SecFilterEngine Off
    #    SecFilterScanPOST Off
    #</IfModule>
    
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    
    <IfModule mod_rewrite.c>
        RewriteEngine On
    
        RewriteCond %{HTTP_HOST} ^www.prteamwork.com/community$ [NC]
        RewriteRule ^(.*)$ http://prteamwork.com/community/$1 [R=301,L]
    
        #    If you are having problems with the rewrite rules, remove the "#" from the
        #    line that begins "RewriteBase" below. You will also have to change the path
        #    of the rewrite to reflect the path to your XenForo installation.
        #RewriteBase /xenforo
    
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data|js|styles|install) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
    </IfModule>
    
    Per this post.
     
  5. addaco

    addaco Member

    still have a few problems with that, trying to figure it out
     
  6. addaco

    addaco Member

    it works :)

    the problems were my browsing history second guessing the site
     

Share This Page