1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to upload Word attachments

Discussion in 'XenForo Questions and Support' started by Core Freedom, Feb 23, 2013.

  1. Core Freedom

    Core Freedom Well-Known Member

    I'm trying to upload Word documents to a post but even though I have added 'doc' as a permitted attachment file, it won't show up on the list when I try to create the attachment. Any suggestions?
  2. Morgain

    Morgain Well-Known Member

    Blueprint - just on case - is it perhaps a .docx?
    I enabled .doc .docx and .rtf and we exchange documents like that constantly.
    Core Freedom likes this.
  3. Ernest L. Defoe

    Ernest L. Defoe Well-Known Member

    Yeah I didn't think about that when I read this thread earlier. Newer versions of Word save the files as .docx
    Core Freedom likes this.
  4. Core Freedom

    Core Freedom Well-Known Member

    I'm still with the stone ages, Word 03, yeewwhaww. So no, it's a doc file. ;)
  5. Core Freedom

    Core Freedom Well-Known Member

    Morgain, what do you mean you "enabled" the extensions? I simply went into options/attachments and added the doc extension. There was nothing to be enabled, unless I'm missing something.
  6. Morgain

    Morgain Well-Known Member

    Sorry I meant what you said.
  7. Shelley

    Shelley Well-Known Member

    Could the attachment be over the kb limit you set for attachments?
    Core Freedom likes this.
  8. Core Freedom

    Core Freedom Well-Known Member

    No, it's set to 2000 and the word doc is only 56 kb.
  9. Ingenious

    Ingenious Well-Known Member

    Have you uploaded any other type of attachment (say an image) to the same thread in the same forum using the same user, to rule out permissions or an unrelated upload issue? Have you tried a different browser or get a different member to try uploading it if you are sure your attachment settings are right? Possibly also try changing the upload limit higher as a test (I set mine at 100000), any effect?

    Do you have any mods/plugins active that relate to attachments?

    Does the file contain any odd characters in the filename, have you tried renaming then uploading, or uploading something basic like a text.doc file with just a short text in?

    When you say it does not appear on the list, do you mean it goes through the motions of uploading and then just vanishes? Do you get an error message and have you checked your error logs?

    As a workaround if you can upload other attachments you could always .zip (compress) the word document before uploading - does that work?

    Does it work trying to attach them to a conversation rather than a post?

    I know some of this stuff is trying to teach you to suck eggs, but it might help just to rule out the obvious first, and narrow down whether this is a server issue, a Xenforo issue, a browser issue, or a problem with the actual file.
    Core Freedom and Morgain like this.
  10. Core Freedom

    Core Freedom Well-Known Member

    Hi Ingenious, this is so odd. I was not able to upload anything and followed your advice, started a personal conversation with a test account and uploaded two word files, one with just two words in it and the 56 kb word file. It accepted both. After I tried uploading the same to the post in the forum and it worked, although it didn't work yesterday. So bizarre. Anyways, it all seems fine now! Thank you!!
    Andrej likes this.
  11. Main Company

    Main Company Active Member

    I've had similar issues. I enable .doc and .docx extensions, but I was still not able to upload them. They didn't even show-up in the upload dialog box.

Share This Page