• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

How much memory needed for ES?

#1
I asked my hosting company to install ES for me, and they replied saying when they attempted to they recieved this message:

root@host [~/elasticsearch-0.90.10/bin]# ./elasticsearch -f
Can't start up: not enough memory
root@host [~/elasticsearch-0.90.10/bin]#
I am wondering how much memory is needed to install it? I am currently running a VPS with 2.5GB of ram for a forum with 300K posts, and our forum runs great. Is there a minimum just to install ES?

Just looked on the server and it looks like were only using ~10-15% of the memory as is.
 
#5
I just recieved this message when trying to turn on enhanced search

Code:
An exception occurred: No response returned from Elasticsearch. Is it running? in /home/oakleyfo/public_html/library/XenES/Search/SourceHandler/ElasticSearch.php on line 777
1.    XenES_Search_SourceHandler_ElasticSearch->_assertIndexSuccessful() in XenES/Search/SourceHandler/ElasticSearch.php at line 67
2.    XenES_Search_SourceHandler_ElasticSearch->finalizeRebuildSet() in DigitalPointSearch/Search/SourceHandler/ElasticSearch.php at line 11
3.    DigitalPointSearch_Search_SourceHandler_ElasticSearch->__destruct() in XenForo/Model/Deferred.php at line 243
4.    XenForo_Deferred_SearchIndex->execute() in XenForo/Model/Deferred.php at line 243
5.    XenForo_Model_Deferred->runDeferred() in XenForo/Model/Deferred.php at line 369
6.    XenForo_Model_Deferred->_runInternal() in XenForo/Model/Deferred.php at line 322
7.    XenForo_Model_Deferred->run() in XenForo/ViewRenderer/Abstract.php at line 352
8.    XenForo_ViewRenderer_Abstract::hasManualDeferredToRun() in XenForo/ViewRenderer/HtmlAdmin.php at line 130
9.    XenForo_ViewRenderer_HtmlAdmin->renderContainer() in XenForo/FrontController.php at line 604
10.    XenForo_FrontController->renderView() in XenForo/FrontController.php at line 158
XenForo_FrontController->run() in /home/oakleyfo/public_html/admin.php at line 13
My hosting company said it was on, but I will double check with them.