1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 How do I edit the default style for links in notices?

Discussion in 'Styling and Customization Questions' started by ithinkitsnice, Feb 8, 2014.

  1. ithinkitsnice

    ithinkitsnice New Member

    Is it possible to edit the default text style for notices in the Style Properties or do I need to add CSS somewhere specific? If so where?

    I can only see settings for background colours etc in the Style Properties. I tried adding this CSS to the misc. box there but it doesn't work.

    color: #ffffff;
    text-decoration: underline;
  2. Amaury

    Amaury Well-Known Member

    A screenshot showing what you want to edit would be helpful.
  3. ithinkitsnice

    ithinkitsnice New Member

    Sorry, I thought 'the default text style for links in notices' was fairly unambiguous, but here you go —

    Screen Shot 2014-02-08 at 17.47.10.png

    So, specifically I'm referring to the styling of the text link in the notice there ("Reopen via..."); I want to the above CSS to apply to that.

  4. Amaury

    Amaury Well-Known Member


    You can change this with the Link style property under General.
  5. ithinkitsnice

    ithinkitsnice New Member

    That will change all links that inherit that property though, won't it?

    I could do that but then wouldn't I have to go through all the other specific link types to redefine them? Can't I target this class specifically?
  6. Amaury

    Amaury Well-Known Member

    Using the Inspect Element tool, I see this: <div class="baseHtml noticeContent">.

    Try doing something with that.
  7. Brogan

    Brogan XenForo Moderator Staff Member

    Create your notice content like so:
    <div class="messageText baseHtml myClass">
    Notice content.
    Add to EXTRA.css:
    .myClass a
    color: red;
    Amaury likes this.
  8. ithinkitsnice

    ithinkitsnice New Member

    @Amaury I can't for the life of me target it

    @Brogan ok that makes sense, will try that later, thanks.

    Strange and a bit frustrating there's not easy control over the styling of this in the options when there is for pretty much everything else.

Share This Page