• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 Hide SubForums on forum index page

Brent W

Well-known member
#1
In vBulletin you could tell it to not list subforums on the forumhome. Is there an option for this on xenForo to not have it render the subforums when you load the homepage of the forum?
 

Brent W

Well-known member
#6
View the source for http://www.cruisingtalk.com/

You can see that all the html for the subforums show up in the source. Seems like there could be a performance gain on page load there was a way not to render that html at all, since I don't want to show subforums on forum index.

Screen Shot 2012-07-29 at 1.59.49 PM.png
 

Jake Bunce

XenForo moderator
Staff member
#7
Oh that's expected. The CSS hides those subforums on the rendered page such that it doesn't matter that the subforums are in the source code. If you want to remove the HTML then you need to edit this template:

Admin CP -> Appearance -> Templates -> node_forum_level_2
 

Brent W

Well-known member
#8
Oh that's expected. The CSS hides those subforums on the rendered page such that it doesn't matter that the subforums are in the source code. If you want to remove the HTML then you need to edit this template:

Admin CP -> Appearance -> Templates -> node_forum_level_2
Thanks. I'll do that for a temporary fix. I opened a suggestion for a feature to not make this a template edit (similar to what many vBulletin users are used to).