• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Help: Unknown column

#1
I get lot of this server error, can someone help:

Error Info
Zend_Db_Statement_Mysqli_Exception: Mysqli prepare error: Unknown column 'social_tokens' in 'field list' - library/Zend/Db/Statement/Mysqli.php:77
Generated By: Unknown Account, Today at 6:49 PM

Thanks in advance,
 
#3
The full error log:

Server Error Log
Error Info
Zend_Db_Statement_Mysqli_Exception: Mysqli prepare error: Unknown column 'social_tokens' in 'field list' - library/Zend/Db/Statement/Mysqli.php:77
Generated By: Unknown Account, 5 minutes ago
Stack Trace
#0 /home/content/93/9706293/html/FMS_Forum/library/Zend/Db/Statement.php(115): Zend_Db_Statement_Mysqli->_prepare('INSERT INTO `xf...')
#1 /home/content/93/9706293/html/FMS_Forum/library/Zend/Db/Adapter/Mysqli.php(381): Zend_Db_Statement->__construct(Object(Zend_Db_Adapter_Mysqli), 'INSERT INTO `xf...')
#2 /home/content/93/9706293/html/FMS_Forum/library/Zend/Db/Adapter/Abstract.php(478): Zend_Db_Adapter_Mysqli->prepare('INSERT INTO `xf...')
#3 /home/content/93/9706293/html/FMS_Forum/library/Zend/Db/Adapter/Abstract.php(574): Zend_Db_Adapter_Abstract->query('INSERT INTO `xf...', Array)
#4 /home/content/93/9706293/html/FMS_Forum/library/XenForo/DataWriter.php(1624): Zend_Db_Adapter_Abstract->insert('xf_user', Array)
#5 /home/content/93/9706293/html/FMS_Forum/library/XenForo/DataWriter.php(1613): XenForo_DataWriter->_insert()
#6 /home/content/93/9706293/html/FMS_Forum/library/XenForo/DataWriter.php(1405): XenForo_DataWriter->_save()
#7 /home/content/93/9706293/html/FMS_Forum/library/bdBank/XenForo/DataWriter/User.php(26): XenForo_DataWriter->save()
#8 /home/content/93/9706293/html/FMS_Forum/library/XenForo/ControllerPublic/Register.php(281): bdBank_XenForo_DataWriter_User->save()
#9 /home/content/93/9706293/html/FMS_Forum/library/XenForo/FrontController.php(347): XenForo_ControllerPublic_Register->actionRegister()
#10 /home/content/93/9706293/html/FMS_Forum/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#11 /home/content/93/9706293/html/FMS_Forum/index.php(13): XenForo_FrontController->run()
#12 {main}
Request State
array(3) {
["url"] => string(53) "https://www.fixmystuff.in/FMS_Forum/register/register"
["_GET"] => array(0) {
}
["_POST"] => array(16) {
["username"] => string(5) "samfi"
["email"] => string(13) "sebafi@web.de"
["password"] => string(8) "********"
["password_confirm"] => string(8) "********"
["dob_month"] => string(1) "8"
["dob_day"] => string(2) "10"
["dob_year"] => string(4) "1963"
["gender"] => string(0) ""
["custom_fields"] => array(4) {
["country"] => string(2) "de"
["google_plus"] => string(0) ""
["facebook"] => string(0) ""
["twitter"] => string(0) ""
}
["custom_fields_shown"] => array(4) {
[0] => string(7) "country"
[1] => string(11) "google_plus"
[2] => string(8) "facebook"
[3] => string(7) "twitter"
}
["timezone"] => string(16) "Europe/Amsterdam"
["recaptcha_challenge_field"] => string(249) "03AHJ_Vusu8lisjCdcxRQUtznuCIsZi9jyvcWxPsDOYhGJ5pAIgID1hSlmrfxU9ZUrqu6HdhDL6XR8WjQug36rBkwxRgoLSdIstUJCCHHTG8ZvxhWIqXisXn03drqjIsEWM8ZR_9EkVncUt65wjXIV0tvXHP5Eyrqk7RPlMwZRQJtiThqOFy2T4g7qUL_ARtzOiTnwXVVP8jXxd98LNob01xeSGj_CTuPbUf9NEfg7IEt3UKh4T27ubyk"
["recaptcha_response_field"] => string(11) "52884685624"
["agree"] => string(1) "1"
["_xfToken"] => string(8) "********"
["reg_key"] => string(32) "16953bd8e843f270a277380ff7c54153"
}
}
 
#4
And this as well:

Server Error Log
Error Info
ErrorException: Undefined index: enabled - library/CTA/FeaturedThreads/ControllerPublic/Thread.php:277
Generated By: Unknown Account, Yesterday at 8:41 AM
Stack Trace
#0 /home/content/93/9706293/html/FMS_Forum/library/CTA/FeaturedThreads/ControllerPublic/Thread.php(277): XenForo_Application::handlePhpError(8, 'Undefined index...', '/home/content/9...', 277, Array)
#1 /home/content/93/9706293/html/FMS_Forum/library/XenForo/FrontController.php(347): CTA_FeaturedThreads_ControllerPublic_Thread->actionFeatured()
#2 /home/content/93/9706293/html/FMS_Forum/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#3 /home/content/93/9706293/html/FMS_Forum/index.php(13): XenForo_FrontController->run()
#4 {main}
Request State
array(3) {
["url"] => string(52) "https://www.fixmystuff.in/FMS_Forum/threads/featured"
["_GET"] => array(0) {
}
["_POST"] => array(0) {
}
}
 

Brogan

XenForo moderator
Staff member
#5
I can't find any reference to 'social_tokens' in the core tables.
I see reference to an add-on there, bdBank, so you may want to check with the developer of that add-on.
 

Chris D

XenForo developer
Staff member
#8
I get lot of this server error, can someone help:

Error Info
Zend_Db_Statement_Mysqli_Exception: Mysqli prepare error: Unknown column 'social_tokens' in 'field list' - library/Zend/Db/Statement/Mysqli.php:77
Generated By: Unknown Account, Today at 6:49 PM

Thanks in advance,
I'm not certain, but I think there is possibly a situation where a column that is used by Friend Inviter or Social Connect could be removed. There's a fix in this post:

http://xenforo.com/community/threads/friend-inviter-paid.35651/page-24#post-615171

I know you use Friend Inviter :) Do you or have you ever used Social Connect also? Has this been uninstalled? They use the same column, and possibly uninstalling one of the two removes the column. But there should be some code to prevent that...