• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Help setting up VPS

DaveL

Well-known member
#1
Ive gone ahead and purchased my VPS, however ive fallen at the first hurdle in trying to set it up.

My old VPS was set up for me and linked to a domain name - server1.mydomain.com and the nameservers were ns1.mydomain.com and ns2.mydomain.com

Im struggling to try and get all the settings correct on my new VPS and was hoping someone may be able to help!

Thanks in advance

Dave
 

DaveL

Well-known member
#4
Right! Ive been playing around with it for ages my im still at a loss for the time being!

On my old VPS I could access it by going to "cpanel.mydomain.com"
On my new VPS, when I type in "cpanel.mydomain.com", it redirects me to an address such as "https://ip-12-345-678-90.ip.secureserver.net:2087/"

Ive set up my namesevers as "ns1.mydomain.com" and "ns2.mydomain.com" and within the domain control panel, ive gone to "host" and pointed each ns1 and ns2 to each IP address.

So far so good....I think!

Ive now added an account in my VPS - mywebsite.com
Ive done as I used too, gone to cpanel.mywebsite.com but it comes back with a server not found error. It also looks like the nameservers are not re-directing.

Really at a loss here! All I want to be able to do is the following!

1)Access root by going to "cpanel.mydomain.com"
2) Have my namservers work
3) When I add an account, be able to access that accounts control panel by going to "cpanel.thewebsite.com"

Any help really really appreciated.

Dave
 

Tracy Perry

Well-known member
#5
Right! Ive been playing around with it for ages my im still at a loss for the time being!

On my old VPS I could access it by going to "cpanel.mydomain.com"
On my new VPS, when I type in "cpanel.mydomain.com", it redirects me to an address such as "https://ip-12-345-678-90.ip.secureserver.net:2087/"

Ive set up my namesevers as "ns1.mydomain.com" and "ns2.mydomain.com" and within the domain control panel, ive gone to "host" and pointed each ns1 and ns2 to each IP address.

So far so good....I think!

Ive now added an account in my VPS - mywebsite.com
Ive done as I used too, gone to cpanel.mywebsite.com but it comes back with a server not found error. It also looks like the nameservers are not re-directing.

Really at a loss here! All I want to be able to do is the following!

1)Access root by going to "cpanel.mydomain.com"
2) Have my namservers work
3) When I add an account, be able to access that accounts control panel by going to "cpanel.thewebsite.com"

Any help really really appreciated.

Dave
Is this a managed or unmanaged VPS?
First thing... it can take 24 hours for an IP->Domain name remap to take effect.
Have you contacted your host to verify that you would browse to cpanel.mydomain.com?
I don't know how exact these are (since I don't use cPanel - I use ZoneEdit for my DNS and dyndns for my registrar)
http://www.websitehostingguide.us/cpanel-nameserver-setup.html
 

DaveL

Well-known member
#6
Is this a managed or unmanaged VPS?
First thing... it can take 24 hours for an IP->Domain name remap to take effect.
Have you contacted your host to verify that you would browse to cpanel.mydomain.com?
I don't know how exact these are (since I don't use cPanel - I use ZoneEdit for my DNS and dyndns for my registrar)
http://www.websitehostingguide.us/cpanel-nameserver-setup.html
Thanks for the reply, I was just coming back to update!

Appears you were spot on. Just checked out a couple of domains I pointed at the new server on my mobile using 3G and they are pointing to the new server. Appears Virgin Media is quite slow at propagation as had this problem before.

Thats a big tick though, means my nameservers are correct!

Just on hold to the new host in regards to accessing cpanel.domain.com rather then domain.com/cpanel. I know its not a biggy, but prefer it that way. Also going to ask as I keep getting security certificate alerts when I try to log into the cpanels.
 

MattW

Well-known member
#7
Thanks for the reply, I was just coming back to update!

Appears you were spot on. Just checked out a couple of domains I pointed at the new server on my mobile using 3G and they are pointing to the new server. Appears Virgin Media is quite slow at propagation as had this problem before.

Thats a big tick though, means my nameservers are correct!

Just on hold to the new host in regards to accessing cpanel.domain.com rather then domain.com/cpanel. I know its not a biggy, but prefer it that way. Also going to ask as I keep getting security certificate alerts when I try to log into the cpanels.
We use VM at work, and they are one of the slowest ISP's for domain updates.
 

DaveL

Well-known member
#8
Ok. sorted out the security certificate issue.

Still at a loss as the cpanel.domain.com

I was told
You would be able to create cnames for cpanel.domain.com that point to account.com/cpanel

You should be able to create a zone template in cpanel to push the changes to new domains


For more information on editing zone templates http://docs.cpanel.net/twiki/bin/view/AllDocumentation/WHMDocs/EditTemplates
Ive had a read through, but still not sure. Does anyone else know how to do this?
 

WSWD

Well-known member
#9
Just on hold to the new host in regards to accessing cpanel.domain.com rather then domain.com/cpanel. I know its not a biggy, but prefer it that way. Also going to ask as I keep getting security certificate alerts when I try to log into the cpanels.
That is the default for cPanel. Has nothing to do with your host or VPS. As far as your certificates, that's because you're accessing the cPanel/WHM via SSL, and are only using a self-signed SSL certificate. If you want those errors to go away, you need to put a SSL cert. on the server, or default the access to cpanel/WHM via non-secured ports (2082, 2086). There is a setting for that in WHM...under Tweak Settings I believe.
 

DaveL

Well-known member
#11
That is the default for cPanel. Has nothing to do with your host or VPS. As far as your certificates, that's because you're accessing the cPanel/WHM via SSL, and are only using a self-signed SSL certificate. If you want those errors to go away, you need to put a SSL cert. on the server, or default the access to cpanel/WHM via non-secured ports (2082, 2086). There is a setting for that in WHM...under Tweak Settings I believe.
Hi WSWD, managed to solve the issue with the certificates by turning it off under the tweaks settings.

Nope, apparently its to do with cnames the host said. I have no idea reading that guide he pointed too, so unfortunalty for the time being will have to settle for domain.com/cpanel
 

WSWD

Well-known member
#12
Hi WSWD, managed to solve the issue with the certificates by turning it off under the tweaks settings.

Nope, apparently its to do with cnames the host said. I have no idea reading that guide he pointed too, so unfortunalty for the time being will have to settle for domain.com/cpanel
They are 100% incorrect...trust me. You absolutely do not have to set up cnames for that to work. By default, cpanel should create the following A entries in the DNS for every single domain:

ftp
webmail
cpanel
whm
webmail
webdisk

That will allow you to access all those things via the domain, i.e. webmail.yourdomain.com, cpanel.yourdomain.com, etc.
 

WSWD

Well-known member
#13
If you go to the DNS editor in WHM, are you seeing A entries for those things in the accounts you created?
 

WSWD

Well-known member
#15
You're missing all the A entries for cPanel, WHM, etc.

See the A entry for ftp, in your screenshot? You should also have cpanel, whm, webmail, webdisk, and all the email autodiscover stuff if you set it up. You're missing all of them except FTP.

Not really sure why they are missing, as they are the default on every single one of our cPanel servers. I'm going out for the next 12 hours or so, but I can set up a test VPS with cPanel later and see what happens. Pretty certain it should be the default though.

In the meantime, you should be able to create A entries for cPanel. Just add a new entry, and make it look exactly like the one for ftp, only call it cpanel instead.
 

DaveL

Well-known member
#16
You're missing all the A entries for cPanel, WHM, etc.

See the A entry for ftp, in your screenshot? You should also have cpanel, whm, webmail, webdisk, and all the email autodiscover stuff if you set it up. You're missing all of them except FTP.

Not really sure why they are missing, as they are the default on every single one of our cPanel servers. I'm going out for the next 12 hours or so, but I can set up a test VPS with cPanel later and see what happens. Pretty certain it should be the default though.

In the meantime, you should be able to create A entries for cPanel. Just add a new entry, and make it look exactly like the one for ftp, only call it cpanel instead.
Hi WSWD,

I added an A entry for cPanel and it worked a treat! I can now access cpanel.domain.com!

When you have time later, if you do set up a test VPS with cPanel, would be great if maybe you could see if theres a way I can automaticvally have the A entries created when I add a new account.

Many thanks for your help so far.

Dave
 

DaveL

Well-known member
#17
Ive just asked the host, and apparentl cpanel, whm, webmain and webdisk are not default records. They have to be added to "Zone templates" to automatically be created when an account is added. Im having a play around, but not have much joy!
 

Tracy Perry

Well-known member
#18

Tracy Perry

Well-known member
#20
Looked at those. Cant locate a variable for cpanel, webdisk etc so put in

cpanel. IN A %nameservera%

But that did not appear in the DNS when I created a new account.
I found an example for a template that shows
%ftpip% -- IP of FTP server for domain

I wonder if doing
%cpanelip% -- IP of Cpanel server for domain
would work?