1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help Pages Wrapper Manager 1.2.3

Control your Help Pages structure

  1. cclaerhout

    cclaerhout Well-Known Member

    cclaerhout submitted a new resource:

    Help Pages Wrapper Manager - Control your Help Pages structure

    Read more about this resource...
     
    Xon likes this.
  2. cclaerhout

    cclaerhout Well-Known Member

    cclaerhout updated Help Pages Wrapper Manager with a new update entry:

    Version 1.1.0 released

    Read the rest of this update entry...
     
  3. cclaerhout

    cclaerhout Well-Known Member

  4. cclaerhout

    cclaerhout Well-Known Member

    cclaerhout updated Help Pages Wrapper Manager with a new update entry:

    Version 1.2.0 released

    Read the rest of this update entry...
     
    RobinHood likes this.
  5. cclaerhout

    cclaerhout Well-Known Member

  6. Freelancer

    Freelancer Well-Known Member

  7. cclaerhout

    cclaerhout Well-Known Member

  8. Glockie

    Glockie Well-Known Member

    Hi @cclaerhout
    I have an issue when clicking the add-on in the options menu;


    Code:
    An exception occurred: Invalid model 'Sedo_HelpWrapperManager_Model_GetUsergroups' specified in mysite//public/library/XenForo/Model.php on line 192
    
        XenForo_Model::create() in Sedo/HelpWrapperManager/Listener.php at line 110
        Sedo_HelpWrapperManager_Listener::helpWrapper_settings()
        call_user_func() in XenForo/ViewAdmin/Helper/Option.php at line 345
        XenForo_ViewAdmin_Helper_Option::_renderCallbackOptionHtml() in XenForo/ViewAdmin/Helper/Option.php at line 72
        XenForo_ViewAdmin_Helper_Option::renderPreparedOptionHtml() in XenForo/ViewAdmin/Helper/Option.php at line 33
        XenForo_ViewAdmin_Helper_Option::renderPreparedOptionsHtml() in XenForo/ViewAdmin/Option/ListOptions.php at line 30
        XenForo_ViewAdmin_Option_ListOptions->renderHtml() in XenForo/ViewRenderer/Abstract.php at line 227
        XenForo_ViewRenderer_Abstract->renderViewObject() in XenForo/ViewRenderer/HtmlAdmin.php at line 78
        XenForo_ViewRenderer_HtmlAdmin->renderView() in XenForo/FrontController.php at line 607
        XenForo_FrontController->renderView() in XenForo/FrontController.php at line 158
        XenForo_FrontController->run() in /home/nginx/domains/mysite.com/public/admin.php at line 13
    
    Hope you can help?
    Thank you. :)
     
    RobinHood likes this.
  9. RobinHood

    RobinHood Well-Known Member

    Yep, same
     
    Glockie likes this.
  10. cclaerhout

    cclaerhout Well-Known Member

    I will fix this tonight.
     
    RobinHood likes this.
  11. cclaerhout

    cclaerhout Well-Known Member

    Glockie likes this.
  12. RobinHood

    RobinHood Well-Known Member

    Thanks for the update Cedric.
    Just trying this out, when embedding posts as help pages videos render properly as embeds, but images just show as text inline:

    View Attachment x

    Is there any way to have them show as full size embedded images? :)
     
    Glockie likes this.
  13. Glockie

    Glockie Well-Known Member

    Indeed thank you for fixing this issue Cedric. :)
     
  14. BobbyWibowo

    BobbyWibowo Well-Known Member

    Is this add-on still being maintained? It was working fine with PHP 7.0.x, but I'm getting this error with PHP 7.1.0:
    Stack info:
     
  15. cclaerhout

    cclaerhout Well-Known Member

    Did you try to propose a fix on Github? I can look for it, but people can do it also. That's the idea of open source.
    The problem is certainly that the pageData is not an array (a string) and php 7.1.0 now wants the variable to be declared as an array to add it values. I will push a fix on Github, but really for such an easy error, admins should give an help.

    Edit: done (ref).
     
    Last edited: Dec 5, 2016 at 9:27 PM
    BobbyWibowo likes this.

Share This Page