1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Header navigation: not 'buttons' anymore?

Discussion in 'XenForo Pre-Sales Questions' started by dutchbb, Dec 3, 2010.

  1. dutchbb

    dutchbb Well-Known Member

    Sorry if this has been reported before, but the header navigation in beta 3 had clickable buttons (Home, Forums,..) and they seem to be just links now on the XF forums (i.e. not 'block' element).

    Is this because of the added snow, or is it a css error that can be fixed?
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Moved to pre-sales and feedback.

    The navigation tabs haven't been changed, there is just a background image which overlays the top half of the tabs, hence why they only work below the lowest edge of the snow graphics.
  3. dutchbb

    dutchbb Well-Known Member

    Ok, I was in doubt if it was the snow background, because the problem occurs on every button, but I understand now; the background covers the complete width of the header.

    Still, I think the buttons that are more to the center shouldn't be affected if there is no image close to them. But I didn't look at the code so maybe there is no other way to do it.
  4. Brogan

    Brogan XenForo Moderator Staff Member

    It's one line of css which is why it affects all tabs.
    background: url(http://xenforo.com/images/shelley_snow_l.png) no-repeat 0% 0%, url(http://xenforo.com/images/shelley_snow_c.png) no-repeat 50% 0%, url(http://xenforo.com/images/shelley_snow_r.png) no-repeat 100% 0%;
  5. Floris

    Floris Guest

    I keep miss-clicking, despite having fine aim. It's getting quite annoying. If this could be addressed that would be great.
  6. Brogan

    Brogan XenForo Moderator Staff Member

    As far as I am aware, the images are going to be reduced in height slightly.

    I tend to use the breadcrumbs for all forum based navigation which obviously avoids the issue.
    Fusion and Floris like this.

Share This Page