• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Header Eating Forum on IE Browsers

DieselMinded

Well-known member
#1
Here is my logo block

Code:
<div id="logoBlock" align="center">
    <div class="pageWidth">
        <div class="pageContent">
            <xen:include template="ad_header" />
            <xen:hook name="header_logo">
            <div id="logo"><a href="{$logoLink}">
                <span><xen:comment>This span fixes IE vertical positioning</xen:comment></span>
                <img src="@headerLogoPath" alt="{$xenOptions.boardTitle}" />
            </a></div></xen:hook>
            <table border="0" width="468" height="145">
    <tr>
        <td height="145" width="468">
        <p align="center">
<iframe id='a017d3a2' name='a017d3a2' src='http://dieseldetails.com/openx/www/delivery/afr.php?resize=1&amp;refresh=0&amp;zoneid=3&amp;target=_blank&amp;cb=INSERT_RANDOM_NUMBER_HERE' frameborder='0' scrolling='no' width='468' height='60' allowtransparency='true'><script type='text/javascript'>
<!--// <![CDATA[
   document.write ("<nolayer>");
   document.write ("<a href='http://dieseldetails.com/openx/www/delivery/ck.php?n=a75c0884&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='http://dieseldetails.com/openx/www/delivery/avw.php?zoneid=3&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=a75c0884' border='0' alt='' /></a>");
   document.write ("</nolayer>");
   document.write ("<ilayer id='layera017d3a2' visibility='hidden' width='468' height='60'></ilayer>");
// ]]> -->
</script><noscript>
  <a href='http://dieseldetails.com/openx/www/delivery/ck.php?n=a017d3a2' target='_blank'>
  <img src='http://dieseldetails.com/openx/www/delivery/avw.php?zoneid=3&target=_blank&cb=INSERT_RANDOM_NUMBER_HERE' border='0' alt='' /></a></noscript></iframe>
 
<!-- Placement Comment -->
<layer src='http://dieseldetails.com/openx/www/delivery/afr.php?n=a017d3a2&zoneid=3&target=_blank&cb=INSERT_RANDOM_NUMBER_HERE&rewrite=0' width='468' height='60' visibility='hidden' onload="moveToAbsolute(layera017d3a2.pageX,layera017d3a2.pageY);clip.width=468;clip.height=60;visibility='show';"></layer></td></tr>
</table>
            <span class="helper"></span>
        </div>
    </div>
</div>
 

DieselMinded

Well-known member
#3
how can i make the logo shrink , i had the ad perfectly placed on fire fox but when i make my window narrower on IE it shoots the ad below the logo and adds the little "play symbols" which is like how many lines of code the header has eaten off the main content area
 

Brogan

XenForo moderator
Staff member
#4
You could probably do it with javascript or try using a max-width attribute, e.g. 80% or whatever works with the current design.
 
#9
That's a problem I've always had when working with XF. I can't tell you off the top of my head how I fixed this problem, because I haven't work with XF themes in a couple of weeks. That's actually one of my only downfalls about styling with XF.
 

DieselMinded

Well-known member
#10
I have my ad_header striped down to

Code:
<xen:hook name="ad_header" />
<iframe id='a017d3a2' name='a017d3a2' src='http://dieseldetails.com/openx/www/delivery/afr.php?resize=1&amp;refresh=0&amp;zoneid=3&amp;target=_blank&amp;cb=INSERT_RANDOM_NUMBER_HERE' frameborder='0' scrolling='no' width='468' height='60' allowtransparency='true' marginwidth="10" marginheight="10" align="middle"><script type='text/javascript'>
<!--// <![CDATA[
   document.write ("<nolayer>");
   document.write ("<a href='http://dieseldetails.com/openx/www/delivery/ck.php?n=a75c0884&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='http://dieseldetails.com/openx/www/delivery/avw.php?zoneid=3&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=a75c0884' border='0' alt='' /></a>");

   document.write ("</nolayer>");
   document.write ("<ilayer id='layera017d3a2' visibility='hidden' width='468' height='60'></ilayer>");
// ]]> -->
</script><noscript>
  <a href='http://dieseldetails.com/openx/www/delivery/ck.php?n=a017d3a2' target='_blank'>
  <img src='http://dieseldetails.com/openx/www/delivery/avw.php?zoneid=3&target=_blank&cb=INSERT_RANDOM_NUMBER_HERE' border='0' alt='' /></a></noscript></iframe>
<!-- Placement Comment -->
<layer src='http://dieseldetails.com/openx/www/delivery/afr.php?n=a017d3a2&zoneid=3&target=_blank&cb=INSERT_RANDOM_NUMBER_HERE&rewrite=0' width='468' height='60' visibility='hidden' onload="moveToAbsolute(layera017d3a2.pageX,layera017d3a2.pageY);clip.width=468;clip.height=60;visibility='show';"></layer>
which is still allowing my open x to run , how ever the ad is too high and when i try to bring it down the logo moves with it ...
 

DieselMinded

Well-known member
#11
Fixed it i had to move the ad-header below the logo on the logo_block template :

PHP:
<div id="logoBlock" align="center">
    <div class="pageWidth">
        <div class="pageContent">
            <xen:hook name="header_logo">
            <div id="logo"><a href="{$logoLink}">
                <span><xen:comment>This span fixes IE vertical positioning</xen:comment></span>
                <img src="@headerLogoPath" alt="{$xenOptions.boardTitle}" />
            </a></div></xen:hook>
<br><br>
<xen:include template="ad_header" />
            <span class="helper"></span>
        </div>
    </div>
</div>
2 <br> brought it to dead center
 

Brogan

XenForo moderator
Staff member
#12
Not quite vertically aligned in Chrome but it looks fine.

Glad you got it sorted.

You could use 2 divs to get it exact, if you wanted.