1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Has the xenforo.og.png been replaced by the message poster's avatar?

Discussion in 'XenForo Questions and Support' started by SneakyDave, Mar 10, 2011.

  1. SneakyDave

    SneakyDave Well-Known Member

    Prior to the 1.0.0 stable release, the Facebook feed of messages liked or referenced from a XenForo site used to include that logo.og.png PNG image that defaulted to the XenForo logo.

    It appears that has been changed so that the message poster's avatar is used as the image in Facebook?

    If so, that's great! And also, is the logo.og.png image used for anything else?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    It's an option when posting a link directly on your wall now.

    You should have a choice of 2 images - the thread starter's avatar or the logo.

    fb.PNG
     
    SneakyDave likes this.
  3. SneakyDave

    SneakyDave Well-Known Member

    I don't see that option anywhere, I'm just "liking" a page, and post an update, it uses the avatar, other times, when a page is just "liked", it seems it uses the logo.og.png.
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    That option only appears when you paste the link directly into your Facebook wall.
    You won't see it when clicking the button.
     
  5. SneakyDave

    SneakyDave Well-Known Member

    ok, I guess I'm just confused on what it decides to pick to use. Maybe when I use the "recommend" button at the bottom, and post an update to fb, it uses my avatar, if I just "like" something, it uses the logo.og.png.

    In this pic, on xenforo.com, I "like" this thread, and I get the logo.og.png, if I like a thread on my site, it used my avatar, but I didn't get a choice of what image to use.
     

    Attached Files:

  6. Brogan

    Brogan XenForo Moderator Staff Member

    Where are you clicking the like button? Here on XenForo.com or your own site?

    It is currently set to default to the logo.
     
  7. SneakyDave

    SneakyDave Well-Known Member

    On my site, it's "like", here, it's the "recommend" button at the bottom of the thread. Let me play with it some more and see if I can find any consistency.
     
  8. Brogan

    Brogan XenForo Moderator Staff Member

    That shouldn't make a difference - it's just a change of the text.

    I haven't been able to get anything other than a logo in my testing over the last 10 minutes or so.
     
  9. SneakyDave

    SneakyDave Well-Known Member

    Maybe it has to do with when the thread was created? I have 2 fb updates in this image, "liked" a few seconds apart, both posted and "liked" by me on the same site. The only difference is that one thread was created before 1.0.0. stable was installed.
     

    Attached Files:

  10. Brogan

    Brogan XenForo Moderator Staff Member

    The thread creation date shouldn't affect it.

    I suspect this is most likely a Facebook caching issue as the logo is the default image and so should always be shown when clicking the like/recommend button.
     
  11. SneakyDave

    SneakyDave Well-Known Member

    Yeah, I don't know, I don't know why it used an avatar in that other fb update. I thought it was a 1.0.0 stable new feature.
     
  12. Brogan

    Brogan XenForo Moderator Staff Member

    The ability to choose an avatar or logo is definitely new in 1.0.0.
    It only became possible after Facebook made changes to their code.
     
  13. SneakyDave

    SneakyDave Well-Known Member

    Was their a suggestion to make the location of the logo.og.png image configurable in admin? I think Kier mentioned that it would be included in an upcoming release.
     
  14. Brogan

    Brogan XenForo Moderator Staff Member

    It was mentioned but not implemented.
    Currently it's only configurable by editing the open_graph_meta template.

    I expect it may appear in the future as an ACP option.
     
  15. Mike

    Mike XenForo Developer Staff Member

    There's now a style property to control it. It's with the logo property. You can point it at a different image there.
     
    SneakyDave likes this.
  16. Brogan

    Brogan XenForo Moderator Staff Member

    Ah yes, a misunderstanding on my part there.
    I thought Dave meant being able to configure the default thumbnail; i.e. the avatar or logo.
     
  17. SneakyDave

    SneakyDave Well-Known Member

    Oh there it is in Header and Navigation / Facebook Open Graph Logo! Thanks.
     
    erich37 likes this.
  18. Peggy

    Peggy Well-Known Member

    Well I just learned something new. Thanks!
     
  19. Peggy

    Peggy Well-Known Member

    Can it be pointed to any image? And it will show on FB?
     
    erich37 likes this.
  20. Brogan

    Brogan XenForo Moderator Staff Member

    Yes.
    It's the same as replacing the logo.og.png image with one of your own.

    This just allows you to specify a different path to avoid it being overwritten during an upgrade.
     

Share This Page