• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Google delays email to external servers

Andy.N

Well-known member
#1
We recently experience delays in getting emails from @gmail.com addresses to @ourdomain.com accounts.
The delay ranges from 1 hour to a day or two.
We used Google App to host our email server briefly for a day when there was some problem. We since then have moved back to our own email server. Not sure if this is a problem.
A google search reveals that many many people have this problem but there does not seem to be a solution or answer.

Anyone with similar problem?
 

Andy.N

Well-known member
#5
There are rumors that Google 1) does not have infrastructure to handle the email volume so they put free gmail delivery on queue 2) gives priority delivery to paid account.

I don't know if they are true but in this time and age where business depends on email, 1 hour delay of sensitive email is a deal-killer, let alone any longer than that.
 

Mr_Bob

Well-known member
#7
I haven't had a problem with my Google Apps email (free version) everything is pretty instant. Is this only affecting free accounts after Google changed their account policies?

Edit: Just ran a test, still instant. Is it possible something with your MX records may be slowing it down (setting the Google priority too low for example)
 

Andy.N

Well-known member
#9
I haven't had a problem with my Google Apps email (free version) everything is pretty instant. Is this only affecting free accounts after Google changed their account policies?

Edit: Just ran a test, still instant. Is it possible something with your MX records may be slowing it down (setting the Google priority too low for example)
If you are responding to me
1) No, I don't use Google App. I used it for a day and turned back to my own server
2) I have my own DNS server by GoDaddy and the MX records point to my mail server

Not sure what else I need to look at to figure this out.

Here is an email header that got delayed over 24 hours

Return-path: <email@somedomain.com>
Envelope-to: andy@quantnet.com
Delivery-date: Thu, 09 Jun 2011 19:42:15 +0000
Received: from mail-pv0-f179.google.com ([74.125.83.179]:56082)
by quantnet.com with esmtp (Exim 4.72)
(envelope-from <email@somedomain.com>)
id 1QUl7P-0005W6-CY
for andy@quantnet.com; Thu, 09 Jun 2011 19:42:15 +0000
Received: by pvf33 with SMTP id 33so911174pvf.10
for <andy@quantnet.com>; Thu, 09 Jun 2011 12:42:01 -0700 (PDT)
Received: by 10.68.34.39 with SMTP id w7mr776471pbi.106.1307546096105;
Wed, 08 Jun 2011 08:14:56 -0700 (PDT)
Received: from [10.0.1.8] (c-24-10-134-192.hsd1.ut.comcast.net [24.10.134.192])
by mx.google.com with ESMTPS id y2sm578080pbi.67.2011.06.08.08.14.52
(version=TLSv1/SSLv3 cipher=OTHER);
Wed, 08 Jun 2011 08:14:54 -0700 (PDT)
Content-Type: text/plain; charset=us-ascii
Mime-Version: 1.0 (Apple Message framework v1082)
Subject: Re: WP application system estimate
From: Israel XXX <email@somedomain.com>
In-Reply-To: <02a201cc2307$17e9c000$47bd4000$@quantnet.com>
Date: Wed, 8 Jun 2011 09:14:51 -0600
Content-Transfer-Encoding: quoted-printable
Message-Id: <79ABD4FD-7768-4946-AB6B-1569047B7FD2@somedomain.com>
References: <F775829C-124C-4ED8-AF02-51E566175671@somedomain.com> <005301cc13f6$9c583210$d5089630$@quantnet.com> <A304FA13-0BD1-41D4-81A1-9DF75BD9BBCD@somedomain.com> <009d01cc1416$e8292b70$b87b8250$@quantnet.com> <7DE253A8-83D2-4E52-BEC6-19850D616E84@somedomain.com> <013101cc1703$5732a7a0$0597f6e0$@quantnet.com> <0DDDA120-EF60-4877-A504-7FF64B03A785@somedomain.com> <020701cc20af$8eb03520$ac109f60$@optonline.net> <0158577A-BAD3-4ADC-8E45-55A186D932F9@somedomain.com> <026301cc21ad$64639b50$2d2ad1f0$@quantnet.com> <1E946C1B-F77C-4E2D-85BE-34AE309BCAB4@somedomain.com> <02a201cc2307$17e9c000$47bd4000$@quantnet.com>
To: <andy@quantnet.com>
X-Mailer: Apple Mail (2.1082)
 

Mr_Bob

Well-known member
#13
With this rate, I may have to reconsider and host my email with Google again.
I know it's probably redundant, but this article lists all the records that should be created, with their relative priorities. You need to list ASPMX.L.GOOGLE.COM first, for example. I know I'm preaching to the choir here, but I'm guilty of some crazier stuff than putting the servers into the wrong order, haha. If that doesn't help, I'd try contacting Google with a copy of your mx records to see if it's them, your host, or yourself. If you have your records set up just like the article says though, chances are it's Google or your host.
 

Andy.N

Well-known member
#14
I know it's probably redundant, but this article lists all the records that should be created, with their relative priorities. You need to list ASPMX.L.GOOGLE.COM first, for example. I know I'm preaching to the choir here, but I'm guilty of some crazier stuff than putting the servers into the wrong order, haha. If that doesn't help, I'd try contacting Google with a copy of your mx records to see if it's them, your host, or yourself. If you have your records set up just like the article says though, chances are it's Google or your host.
Let me say this again.
I used Google App for my email domain for a day or two (did all the MX changes, etc).
It worked fine. No complaint.

But I have since gone back to my original email server and reverted the MX record to original.

The problem with email delays is not with people who use their Google App but people who don't use it.
 

ENF

Well-known member
#15
Andy, is that domain (quantnet.com) the one that was affected?

I just ran some basic tests for that domain and came back with the following issues you may want to address related to mail delivery:

WARNING: DNS server returned a CNAME. This is an unusual situation -- the following MX tests may not work properly. The problem is:
smtp.quantnet.com.->quantnet.com.
mail.quantnet.com.->quantnet.com.

WARNING: One or more of your MX records points to a CNAME. CNAMEs are prohibited in MX records, according to RFC974, RFC1034 3.6.2, RFC1912 2.4, and RFC2181 10.3. The problem MX record(s) are:
smtp.quantnet.com.->quantnet.com.->184.106.173.69
mail.quantnet.com.->quantnet.com.->184.106.173.69

WARNING: You have duplicate MX records. Although technically valid, this is very confusing, and wastes resources. The duplicate MX records are:
smtp.quantnet.com. and mail.quantnet.com. both resolve to 184.106.173.69.

SPF Record: Does not exist.
Not sure what your configuration was before, but I believe having those CNAMES in place could potentially cause problems. The more direct point is that some mail servers, when finding a CNAME will re-start the look-up process in an attempt to find a true MX records. Thus, this could cause delivery delay.

If this isn't the domain, then sorry... but whichever, that domain should be looked at for the MX records configs.

(PS: We do and do not use Google Apps in various web applications for mail services, we've not noticed any delays in delivery times in either the Google hosted ones or the non-Google operations.)
 

Andy.N

Well-known member
#16
Andy, is that domain (quantnet.com) the one that was affected?

I just ran some basic tests for that domain and came back with the following issues you may want to address related to mail delivery:
ENF
Thank you very much
That's the effected domain.
I'll send you PM and very much appreciate your help.
 

ENF

Well-known member
#18
sad
Hi,

Based on the screenshot above, delete one of the mx records. You only need one since it's going to the same IP address. (If you have a backup MX handler on another server, add it here.)

Secondly, remove the prefix. either 'mail' or 'smtp' -- that's going to the CNAME alias as opposed to just letting other mail servers go directly to your mail server at your main IP address.

So under MX records, it should like like:

10 @ quantnet.com

Edit: I am sorry for the delay, I saw your PM too... hope this helps you out. Re-run the tests after the changes are propagated (shouldn't take long with GoDaddy...).
 

Andy.N

Well-known member
#19
sad
Hi,

Based on the screenshot above, delete one of the mx records. You only need one since it's going to the same IP address. (If you have a backup MX handler on another server, add it here.)

Secondly, remove the prefix. either 'mail' or 'smtp' -- that's going to the CNAME alias as opposed to just letting other mail servers go directly to your mail server at your main IP address.

So under MX records, it should like like:

10 @ quantnet.com

Edit: I am sorry for the delay, I saw your PM too... hope this helps you out. Re-run the tests after the changes are propagated (shouldn't take long with GoDaddy...).
Thanks for your help.

I have updated the screenshot above with latest shot of DNS setting

1) I removed one of the MX record
2) I remove mail.quantnet.com in the CNAME and keep only smtp.quantnet.com

The test http://www.intodns.com/quantnet.com seems clear now.
http://www.mxtoolbox.com/ does not turn up anything wrong.

Yet, email from my gmail account still haven't arrived after several hours.
 

Adam Howard

Well-known member
#20
Yahoo (and those under them) typically gives us problems when members need to confirm registration.

Never had an issue with Google. Sometimes a delay with Hotmail / Live / MSN (Microsoft)