1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Full Friendly URLS

Discussion in 'Troubleshooting and Problems' started by DaniD, Apr 22, 2015.

  1. DaniD

    DaniD Active Member

    Hello,

    I have enabled this and have both .htaccess files and htaccess.txt files. And now apparently an htaccess.bak file. I ensured the mod_rewrite permissions were in place, as well, and asked my host.

    My forum still will not work without the "/index.php", and it's running on Apache. I'm not sure what the issue is at this point. Any help? And I have looked through various threads, all which did not help. Thank you!
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    If you are sure the .htaccess file is in place, can you confirm with the host that AllowOverride is also permitted?

    That should either be in httpd.conf or the Vhost configuration.
     
  3. DaniD

    DaniD Active Member

    Yes, they sent me this to confirm:

    root@host [40 00:52:44 ~]# httpd -l|grep rew
    mod_rewrite.c

    They tried going in themselves to fix it but could not, so now I'm not sure what to do.
     
  4. Mike

    Mike XenForo Developer Staff Member

    I just get a 403 on the site listed in the customer area (and a not found with index.php), so I don't know if that URL is correct. Can you confirm where we can see this problem?
     
  5. DaniD

    DaniD Active Member

    Hi Mike,

    I am uninstalling everything and am going to be doing a fresh install. I will check back in and let you know if there is still an issue - thanks!
     
  6. DaniD

    DaniD Active Member

    Nevermind - got it working after much tinkering. Thanks for everyone's help.
     
  7. mikelowrey

    mikelowrey Active Member

    Sorry to hijack this thread, but after enabling the friendly urls, having both .htaccess and adding the web.config files, I am not getting anywhere... Am I missing anything?
     
  8. DaniD

    DaniD Active Member

    Check to see if the bolded is allowed. If it is, then there's another issue that may be related to the way you uploaded Xenforo. In my case there was an index.php error, and that would be server-side, so you'd have to ask your host.
     
  9. mikelowrey

    mikelowrey Active Member

    Yes, I am waiting on an answer on that as I type this. Thank you.
     
  10. mikelowrey

    mikelowrey Active Member

    @DaniD MY host is telling me that I can activate that by simply creating a .htaccess files with the rules, but where do i get the rules from?
     
  11. Brogan

    Brogan XenForo Moderator Staff Member

    You should already have a default .htaccess file in place.
    If not, rename htaccess.txt.
     
    DaniD likes this.
  12. mikelowrey

    mikelowrey Active Member

  13. Brogan

    Brogan XenForo Moderator Staff Member

  14. mikelowrey

    mikelowrey Active Member

    I did all the steps, the code for ISS 7 I put it into a file and saved it as web.config and uploaded it to the root folder and still nothing. My Host said I can enable the allowoverride with a .htaccess, but where do i get that coding to enable the allow and mod_. Or I have to add the ISS 7 code into the .htaccess?
     
  15. Mike

    Mike XenForo Developer Staff Member

    The example URL you gave does have the "friendly URLs" option enabled. It has "Include Content Title in URLs" disabled though.
     
  16. mikelowrey

    mikelowrey Active Member

    Ahh @Mike Thanks for the clarification. So I just enabled it, so I guess I should be good to go now.
     
  17. mikelowrey

    mikelowrey Active Member

    Yep now it is working! Thank you so much gentlemen, you are the best.
     

Share This Page