1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Friendly urls

Discussion in 'Installation, Upgrade, and Import Support' started by D37, Oct 24, 2010.

  1. D37

    D37 Active Member

    What do I need to have in the .htaccess file to enable friendly urls?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    It's enabled in the ACP.
    Options -> Search Engine Optimisation (SEO) -> Use Full Friendly URLs

    acp_friendly_urls.PNG
     
    beduino likes this.
  3. D37

    D37 Active Member

    It says I need a .htacces file.. and I'm wondering what I have to put in it..
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    If you have an Apache server then an .htacess file will be there provided with the software.
    All you need to do it check the box.
     
  5. D37

    D37 Active Member

    Ok I see. I don't see a .htaccess file on the server so I'll go ahead and upload a blank one.
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    There should be an .htaccess file in the directory where you installed the forum.
    What server are you running?
     
  7. D37

    D37 Active Member

    I checked the xenforo upload folder and see that there is a .htaccess file. I uploaded that file to the server and it now works. When I'm viewing the xenforo upload folder regularly the .htaccess file does not show up, but when I view the folder through "FileZilla ftp" the file is being shown... maybe I have to change my viewing settings on my computer (Mac)
     
  8. Brogan

    Brogan XenForo Moderator Staff Member

    The .htaccess file is hidden so you will need to enable the setting to view hidden files.
     

Share This Page