1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

forum moved to another server, doesn't work

Discussion in 'Installation, Upgrade, and Import Support' started by Robby, Mar 14, 2013.

  1. Robby

    Robby Well-Known Member

    Hello,

    So I moved my forum to another server, i uploaded the files, implemented the database ans all i get is the welcome screen but nu functionality works. I can't login to the admin cp, what can be the problem.
    My board--->www.robbydeletter.com/forum
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I see a few things going on. It appears that XenForo's .htaccess file is not there and that another .htaccess is in play here. Make sure XenForo's .htaccess file is in the /forum directory. And since there is another .htaccess file in play you might need to specify RewriteBase in your .htaccess file (specify the name of your forum directory):

    RewriteBase /forum

    The line should already be there, it's just commented.
     
  3. Robby

    Robby Well-Known Member

    How do i specify the forum directory in the htacces file
     
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Code:
    RewriteBase /forum
    
    Code:
    #	Mod_security can interfere with uploading of content such as attachments. If you
    #	cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #	SecFilterEngine Off
    #	SecFilterScanPOST Off
    #</IfModule>
    
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    
    <IfModule mod_rewrite.c>
    	RewriteEngine On
    
    	#	If you are having problems with the rewrite rules, remove the "#" from the
    	#	line that begins "RewriteBase" below. You will also have to change the path
    	#	of the rewrite to reflect the path to your XenForo installation.
    	RewriteBase /forum
    
    	#	This line may be needed to enable WebDAV editing with PHP as a CGI.
    	#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    
    	RewriteCond %{REQUEST_FILENAME} -f [OR]
    	RewriteCond %{REQUEST_FILENAME} -l [OR]
    	RewriteCond %{REQUEST_FILENAME} -d
    	RewriteRule ^.*$ - [NC,L]
    	RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    	RewriteRule ^.*$ index.php [NC,L]
    </IfModule>
    
     
  5. Robby

    Robby Well-Known Member

    thanks for the advice but still doesn't work...
     
  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Then give me FTP access. I will take a look.
     
  7. Robby

    Robby Well-Known Member

    I get this answer from my host:

    Robby,

    When I go to http://www.robbydeletter.com/forum/ the forum loads almost instantly.

    I do see the 404 when I click on a topic in the forum.
    - Most forums come with redirects that need to be implemented.

    If you can provide these rewrites to us for Apache or NGINX we will get them implemented for you.

    What now?
    What a nightmare moving over my forum, the forum loads but it gives constantly 404's.

    Anybody?

    forum location: www.robbydeletter.com/forum

    Grtz,
    Robby
     
  8. Biker

    Biker Well-Known Member

    Are you using the .htaccess file that comes with XF? Or did you leave the old one in place?
     
  9. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    They need to click some links. For example, this one:

    http://www.robbydeletter.com/forum/forums/vraag-het-aan-robby.28/

    I get either a 404 or 502 error on this page. Something funny is going on with your server and I don't know what.

    Or these links which are apparently being handled by Wordpress:

    http://www.robbydeletter.com/forum/members/
    http://www.robbydeletter.com/forum/help/

    I checked all of your .htaccess files. In fact, I tried temporarily removing the WP .htaccess file but it had no effect. I am guessing there are offending rewrite rules directly in your server config.
     
  10. Robby

    Robby Well-Known Member

    Yeah they speak about rewrites, but where can i find them?:(
     
  11. Robby

    Robby Well-Known Member

    i used the old one
     
  12. Biker

    Biker Well-Known Member

    Make the necessary changes to the one that comes with XF and put it up on the server. I imagine that will fix your issues.
     
  13. Robby

    Robby Well-Known Member

    Nope, tried that, just the same,
    are there any rerwrite rules for xenforo?
     
  14. MattW

    MattW Well-Known Member

    Is there anything set in your apache config that is doing the re-writes rather than the .htaccess?
     
    Jake Bunce likes this.
  15. Robby

    Robby Well-Known Member

    It's a server for wordpress hosting but normally it should work.
    Thet have their own system but of that I don't know...
     
  16. Robby

    Robby Well-Known Member

    I do see the 404 when I click on a topic in the forum.
    - Most forums come with redirects that need to be implemented.

    If you can provide these rewrites to us for Apache or NGINX we will get them implemented for you.

    Do they excist for xenforo?
     
  17. lazy llama

    lazy llama Well-Known Member

    Jake Bunce and Robby like this.
  18. Biker

    Biker Well-Known Member

    Yes. They're included in the .htaccess file that comes with XF. Provide that information to your host.
     
  19. Robby

    Robby Well-Known Member

    Thanks, i'm sending this to my host including the .htacces file...hoping for the best
     
  20. MattW

    MattW Well-Known Member

    This is what I have for friendly URLs on my test site that is running nginx

    Code:
    location / {
     
      # Enables directory listings when index file not found
      #autoindex  on;
     
      # Shows file listing times as local time
      #autoindex_localtime on;
     
      # Enable for vBulletin usage WITHOUT vbSEO installed
      #try_files            / /index.php;
     
      }
     
      location /xenforo/ {
          index index.php index.html index.htm;
          try_files $uri $uri/ /xenforo/index.php?$uri&$args;
      }
     
      location ~ ^/xenforo/(internal_data|library)/ {
      internal;
      allow 127.0.0.1;
      deny all;
      }
     
    Jake Bunce and Biker like this.

Share This Page