• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Forum Description Question

#1
Hello,

Can I set the forum description to appear just beneath the forum title as well as having the grey hover popup that's there now?

Thanks.

Ken
 

Chris D

XenForo developer
Staff member
#2
In node_forum_level_2 template

Change:

Code:
<xen:if is="{$forum.description} AND @nodeListDescriptions">
<blockquote class="nodeDescription {xen:if @nodeListDescriptionTooltips, nodeDescriptionTooltip} baseHtml" id="nodeDescription-{$forum.node_id}">{xen:raw $forum.description}</blockquote>
</xen:if>
To:

Code:
<xen:if is="{$forum.description} AND @nodeListDescriptions">
<blockquote class="nodeDescription nodeDescriptionTooltip baseHtml" id="nodeDescription-{$forum.node_id}">{xen:raw $forum.description}</blockquote>
<blockquote class="nodeDescription baseHtml">{xen:raw $forum.description}</blockquote>
</xen:if>
 

Jainic

Active member
#5
Hello,

Can anyone confirm that this template edit makes descriptions show up twice on an ipad/iphone? On my ipad, there's two descriptions on top of one another.
Is there a way to remove the duplicated description?
Or how to remove the hover pop-up and just have the description underneath the node title? Thanks!
 

Jainic

Active member
#6
I think I got it. I just removed the first blockquote so it removes the description pop-up.
For anyone interested :
Code:
<xen:if is="{$forum.description} AND @nodeListDescriptions">
<blockquote class="nodeDescription baseHtml">{xen:raw $forum.description}</blockquote>
</xen:if>
Edit : You don't need template edits to do this, read the next posts.
 

Chris D

XenForo developer
Staff member
#7
Were you trying just to show the forum description instead of having it as a tooltip pop up? You don't need a template edit for that. You just need to change the relevant style property.
 

Jainic

Active member
#8
Lol silly me. I've been working with TMS and templates all day and forgot about style properties :sleep: .

This :
Admin CP -> Appearances -> Style Properties -> Forum/Node List -> Settings -> Show Forum Descriptions on Node List and Enable Forum Descriptions Tooltips


 

Chris D

XenForo developer
Staff member
#9
That's it :)

Thanks for pointing out the iPad thing though, I forgot about that. I think I can get around it...
 

Jeff Fuqua

Well-known member
#11
I have the same issue but would rather have the description on the node list if at all possible. Is there any way to work this so it doesn't double up on the iPad?
 

Jainic

Active member
#14
@Jeff Fuqua

Yes, to have description on the node list at all times (without the hover popup description) you need to go to :

Admin CP -> Appearances -> Style Properties -> Forum/Node List -> Settings -> Show Forum Descriptions on Node List and Enable Forum Descriptions Tooltips
 

Jeff Fuqua

Well-known member
#15
Here is where I am confused. I have that setting on. I get one description on my laptop browser but it puts two on my iPad. To correct the iPad, I have to uncheck both which leaves me with no description.

I may be missing the obvious but how do I get rid of the double-description on my iPad?
 

Jainic

Active member
#16
Nope, I would do this :



Forum Descriptions Tooltips = Hover description pop-up (which is why you have 2 descriptions showing on the ipad)
 

Jainic

Active member
#18
Strange. Have you made any changes in the template? Did you try resetting safari and iPad?

Is your site live? You can pm me your site and I'll check on my iPhone and iPad if you want.
 

Jainic

Active member
#20
I see two descriptions on my iPad and iPhone like you said.

Could you go to : AdminCP - Appearances - Templates (make sure the correct skin is selected) - node_forum_level_2

Could you copy and paste what is in the node_forum_level_2?