1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Forum Description Question

Discussion in 'Styling and Customization Questions' started by Kenneth Holland, Jun 5, 2012.

  1. Kenneth Holland

    Kenneth Holland Active Member

    Hello,

    Can I set the forum description to appear just beneath the forum title as well as having the grey hover popup that's there now?

    Thanks.

    Ken
     
  2. Chris D

    Chris D XenForo Developer Staff Member

    In node_forum_level_2 template

    Change:

    Code:
    <xen:if is="{$forum.description} AND @nodeListDescriptions">
    <blockquote class="nodeDescription {xen:if @nodeListDescriptionTooltips, nodeDescriptionTooltip} baseHtml" id="nodeDescription-{$forum.node_id}">{xen:raw $forum.description}</blockquote>
    </xen:if>
    To:

    Code:
    <xen:if is="{$forum.description} AND @nodeListDescriptions">
    <blockquote class="nodeDescription nodeDescriptionTooltip baseHtml" id="nodeDescription-{$forum.node_id}">{xen:raw $forum.description}</blockquote>
    <blockquote class="nodeDescription baseHtml">{xen:raw $forum.description}</blockquote>
    </xen:if>
     
    Kenneth Holland and Jake Bunce like this.
  3. Kenneth Holland

    Kenneth Holland Active Member

    Hi Yorick,

    Thanks for this! I've yet to change it yet but will try this.

    Thanks again. :)

    Ken
     
    Yorick likes this.
  4. Chris D

    Chris D XenForo Developer Staff Member

    Welcome :)

    Good luck with it
     
  5. Jainic

    Jainic Active Member

    Hello,

    Can anyone confirm that this template edit makes descriptions show up twice on an ipad/iphone? On my ipad, there's two descriptions on top of one another.
    Is there a way to remove the duplicated description?
    Or how to remove the hover pop-up and just have the description underneath the node title? Thanks!
     
  6. Jainic

    Jainic Active Member

    I think I got it. I just removed the first blockquote so it removes the description pop-up.
    For anyone interested :
    Code:
    <xen:if is="{$forum.description} AND @nodeListDescriptions">
    <blockquote class="nodeDescription baseHtml">{xen:raw $forum.description}</blockquote>
    </xen:if>
    Edit : You don't need template edits to do this, read the next posts.
     
  7. Chris D

    Chris D XenForo Developer Staff Member

    Were you trying just to show the forum description instead of having it as a tooltip pop up? You don't need a template edit for that. You just need to change the relevant style property.
     
  8. Jainic

    Jainic Active Member

    Lol silly me. I've been working with TMS and templates all day and forgot about style properties :sleep: .

    This :
    Admin CP -> Appearances -> Style Properties -> Forum/Node List -> Settings -> Show Forum Descriptions on Node List and Enable Forum Descriptions Tooltips


     
    ragtek and Yorick like this.
  9. Chris D

    Chris D XenForo Developer Staff Member

    That's it :)

    Thanks for pointing out the iPad thing though, I forgot about that. I think I can get around it...
     
  10. Jainic

    Jainic Active Member

    Awesome Yorick (y)
     
  11. Jeff Fuqua

    Jeff Fuqua Well-Known Member

    I have the same issue but would rather have the description on the node list if at all possible. Is there any way to work this so it doesn't double up on the iPad?
     
  12. erich37

    erich37 Well-Known Member

  13. Jeff Fuqua

    Jeff Fuqua Well-Known Member

    If that's for me, I don't understand the solution. To remove the double description, I have to turn it off entirely.
     
  14. Jainic

    Jainic Active Member

    @Jeff Fuqua

    Yes, to have description on the node list at all times (without the hover popup description) you need to go to :

    Admin CP -> Appearances -> Style Properties -> Forum/Node List -> Settings -> Show Forum Descriptions on Node List and Enable Forum Descriptions Tooltips
     
    Yorick likes this.
  15. Jeff Fuqua

    Jeff Fuqua Well-Known Member

    Here is where I am confused. I have that setting on. I get one description on my laptop browser but it puts two on my iPad. To correct the iPad, I have to uncheck both which leaves me with no description.

    I may be missing the obvious but how do I get rid of the double-description on my iPad?
     
  16. Jainic

    Jainic Active Member

    Nope, I would do this :

    [​IMG]

    Forum Descriptions Tooltips = Hover description pop-up (which is why you have 2 descriptions showing on the ipad)
     
  17. Jeff Fuqua

    Jeff Fuqua Well-Known Member

    This is my settings now and I continue to get doubles on the iPad2 in Safari.
     
  18. Jainic

    Jainic Active Member

    Strange. Have you made any changes in the template? Did you try resetting safari and iPad?

    Is your site live? You can pm me your site and I'll check on my iPhone and iPad if you want.
     
  19. Jeff Fuqua

    Jeff Fuqua Well-Known Member

  20. Jainic

    Jainic Active Member

    I see two descriptions on my iPad and iPhone like you said.

    Could you go to : AdminCP - Appearances - Templates (make sure the correct skin is selected) - node_forum_level_2

    Could you copy and paste what is in the node_forum_level_2?
     

Share This Page