1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Flash uploader not working, but non-flash uploader working fine.

Discussion in 'Troubleshooting and Problems' started by TimWF, Jan 21, 2011.

  1. TimWF

    TimWF Active Member

    Upon attempting to upload with the flash uploader enabled the upload progress bar shows up, but no progress ever occurs. (See attached screenshot) It just stays at 0% indefinitely unless you cancel it. Uploads of the same images work fine with the non-flash upload method.

    Within the JS Console the following is logged:

    A bit of info on our troubleshooting so far, we have looked into the apache settings detailed in the following thread and they don't help us (we don't even actually use that module so I didn't expect it would):

    http://xenforo.com/community/threads/upload-attachment-avatar-language-problems.8206/

    Any ideas?
     

    Attached Files:

    Sergio Bambaren likes this.
  2. Mike

    Mike XenForo Developer Staff Member

    No errors logged in Apache about it?
     
  3. TimWF

    TimWF Active Member

    Strangely enough no, we aren't seeing any apache or php errors reported either.
     
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I have seen mod_security interfere with the flash uploader. Try uncommenting this code from xenForo's .htaccess file:

    Code:
    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    <IfModule mod_security.c>
        SecFilterEngine Off
        SecFilterScanPOST Off
    </IfModule>
    
     
  5. Mike

    Mike XenForo Developer Staff Member

    I'm really not sure what would cause this - I see the console is reporting the upload is complete, but it's never hitting (or reporting) 100%. The mod_security issues did still report 100% and you say you're not using that anyway. Would it be possible to get access to a test user to look at this?
     
  6. TimWF

    TimWF Active Member

    Yea we don't have mod_security installed and the symptoms we are seeing are a bit different than the ones described with mod_security as well.

    Mike, I'll see about getting you access to it, I'll let you know. Thanks,
     
  7. TimWF

    TimWF Active Member

    I have started a private conversation to communicate the access details to you Mike. Thanks!
     
  8. TimWF

    TimWF Active Member

    Mike solved this one for us. :)

    If you are htaccess protecting a site you are building some browser/os combos will not give flash the credentials you are using to access the site to flash (and won't ask for them again) resulting in this hang. Thanks!
     
  9. Mike

    Mike XenForo Developer Staff Member

    It worked on Windows with a separate IE htaccess prompt, but it doesn't look like it worked on the Mac at all. Unfortunately this is a very long standing Flash issue and I haven't seen any progress from Adobe towards fixing it.
     
  10. RobParker

    RobParker Well-Known Member

    Having this problem on my mac (and used to have it on vbulletin with flash uploaders as well).

    Assume the only option is to disable the flash uploader?
     
  11. TimWF

    TimWF Active Member

    If you are in a test area that you are protecting with an htaccess password from what I saw that is your only option, but if you are just behind the htaccess for now and plan to remove that later on, it works without a hitch once you are not behind the htaccess. So if it is just testing you could also just wait it out till you go live. :)
     
  12. RobParker

    RobParker Well-Known Member

    As it's my only install I made it accessible but it still doesn't work.

    The only htaccess is the htaccess.txt file that comes with the download. I've uncommented the lines Jake suggested but it didn't help.
     
  13. steven s

    steven s Well-Known Member

    Same problem for me.

    Uncommented htaccess section as Jake suggested in post 4.
    Unchecked Flash loader in the admin section and now can upload files.

    My forum is /forum.
    I have a separate htaccess file in the root directory.
    Could a problem be there?

    Before I noticed this I have noticed members uploading avatars.
     
  14. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    mod_security? Directory login? And what is in the .htaccess file?
     
  15. steven s

    steven s Well-Known Member

    Can I send you the htaccess file in a PC?
     
  16. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  17. Hrabal

    Hrabal New Member

    May I know
    May I know how you fixed the issue? I have the similar problem.
     
  18. ProCom

    ProCom Active Member

    **** FIXED *****

    I recently moved hosting companies from one VPS to Linode. After the move everything was working fine, but I started having members complaining that some images were not uploading properly.

    They would upload an attachment (image) and the progress bar would hit 100% and then nothing would happen.

    After a bunch of researching, I changed the following settings for PHP and MySQL to match my previous VPS. I'm unfortunately not sure which one was successful in fixing the problem, but wanted to post here (and a few other related threads) to share that this worked for me!

    pico /usr/local/lib/php.ini
    memory_limit = from 32M to 158M


    pico /etc/my.cnf
    max_allowed_packet=268435456 to max_allowed_packet=64M
    wait_timeout=10 to 45

    (make sure to restart your services after you make the changes)
     
    Last edited: Mar 8, 2016

Share This Page