1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Firefox 9 beta: no text box on create topic

Discussion in 'Resolved Bug Reports' started by optrex, Nov 14, 2011.

  1. optrex

    optrex Active Member

    Using firefox 9 beta, you will currently be unable to post a new thread as the text box does not appear. You will therefore not be able to add any message content, which will prevent thread creation.

    Reply does not seem to be affected, neither is advanced reply.

    XF 1.0.4
     

    Attached Files:

  2. Kier

    Kier XenForo Developer Staff Member

    A complete absence of the editor suggests a TinyMCE incompatibility. I'll take a look to check that it's not something we're doing in XenForo, but we're not likely to spend a lot of time on it while Firefox 9 is still in beta.
     
  3. DSF

    DSF Well-Known Member

    FF9 and xF works perfekt. ($M and MAC)
     
  4. Kier

    Kier XenForo Developer Staff Member

    Yes, I've just tested it here and although it failed to load the first time, a quick refresh and it worked fine.

    Can anyone consistently reproduce this?
     
  5. DSF

    DSF Well-Known Member

    It works anytime!

    2.jpg
     
  6. Fuhrmann

    Fuhrmann Well-Known Member

    Here, even if I refresh the page, still do not appear the text box. Firefox 9, XenForo 1.1 BETA 5:

    imagem.PNG

    After a few refreshes:

    1.PNG
     
  7. Crazy-Achmet

    Crazy-Achmet Active Member

    I had the same problem over here. Also after a few refreshes it suddenly appeared.
     
  8. Kier

    Kier XenForo Developer Staff Member

    I'd be more concerned if this were a stable version of the browser, but it's called Beta for a reason, and there have been a lot of JS changes from what I've read. I don't think there's anything we can do about it, but I'm not going to chase it around with a beta version of the browser.
     
    Markos, Andrej, Doctor and 1 other person like this.
  9. optrex

    optrex Active Member

    I can reproduce it here too. I was unsure that it was a browser issue though and my reasons are this:
    • It works for a reply
    • It works for advanced...more options
    • It works on creating an event on a mod I run
    This left me feeling it was a template issue for create new topic.
    Thoughts?
     
  10. jacko

    jacko Active Member

    confirmed here
     
  11. DRE

    DRE Well-Known Member

    Confirmed here. I've switched to Google Chrome though. I noticed the site looks way better in Chrome too.
     
  12. Brandon Sheley

    Brandon Sheley Well-Known Member

  13. ShadyX

    ShadyX Well-Known Member

    This makes me glad that I am still using FF8 :cool:
     
  14. Mike

    Mike XenForo Developer Staff Member

    This does seem like a browser issue -- it looks like FF9 introduced a new console object (or new code for it), and it kills JS internally if given a bad variable (forced to display as an object). If you have Firebug enabled, you won't see this issue.

    In js/xenforo/xenforo.js, the fix is to change:
    Code:
    console.info('Title Element: %o', this.$title);
    to:
    Code:
    console.info('Title Element: %o', $title);
    Here's the FF bug report now: https://bugzilla.mozilla.org/show_bug.cgi?id=704014
     
    Kim, Brandon Sheley, steven s and 2 others like this.
  15. DRE

    DRE Well-Known Member

    I have Firefox 9 Beta. I did the change you listed then cleared the browser's cache but the text box still does not appear.
     
  16. optrex

    optrex Active Member

    same for me, although I do notice its been fixed on the XF forum now, I can't get it to pick up on mine
     
  17. Jeremy

    Jeremy XenForo Moderator Staff Member

    You have to wait till 1.1RC2
     
  18. optrex

    optrex Active Member

    I've made the edit and it actually then creates the problem in other versions of firefox, chrome and safari, so I've reverted back
     
  19. darkrounge

    darkrounge Member

    So, there is a fix for this? Or do we have to wait until a new firefox is released :/
     
  20. optrex

    optrex Active Member

    1.1.1 was released in Dec and it fixes the issue
     

Share This Page