1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

fgets() fwrite() in Xenforo error log

Discussion in 'Troubleshooting and Problems' started by Andy.N, Sep 4, 2011.

  1. Andy.N

    Andy.N Well-Known Member

    I have been getting dozen of these errors in Xenforo server log. I know Mike and Kier are busy working on XF 1.1 so I will try this venue first before sending them a ticket.

    I notice that all of these errors come from the Mail class and looking at the detail of each error, it resulted from actions that will generate an email from the server (such as when a member sends another member a PC which will generate an email notification).

    And it's important to note that I use Google STMP service instead of the server email.

    Here are the errors I get (just posting the message)

    • fgets(): SSL: Connection reset by peer library/Zend/Mail/Protocol/Abstract.php:364
    • fwrite(): SSL operation failed with code 1. OpenSSL Error messages: error:1409F07F:SSL routines:SSL3_WRITE_PENDING:bad write retry library/Zend/Mail/Protocol/Abstract.php:324
    • fwrite(): SSL: Broken pipe library/Zend/Mail/Protocol/Abstract.php:324
     
    GencnesilleR likes this.
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Are any emails getting out?

    This looks like a failed SMTP connection. Possible causes include:

    1) A problem with OpenSSL on your server.

    2) Wrong port. I found reports of people fixing this problem by changing the SMTP port:

    http://mail.google.com/support/bin/answer.py?hl=en&answer=13287

     
    GencnesilleR likes this.
  3. Andy.N

    Andy.N Well-Known Member

    I'm changing SSL connection port from 465 to 587 so let's hope that will fix it.
    Thanks a lot Jake.
     
    GencnesilleR likes this.
  4. Andy.N

    Andy.N Well-Known Member

    GencnesilleR likes this.
  5. Brogan

    Brogan XenForo Moderator Staff Member

    Google only allows 465 with SSL doesn't it?
     
    GencnesilleR likes this.
  6. Andy.N

    Andy.N Well-Known Member

    That's correct. The link Jake posted make it look like you can change the port but it does not work
    If you're having trouble sending mail but you've confirmed that encryption is active for SMTP in your mail client, try to configure your SMTP server on a different port (465 or 587).
     
    GencnesilleR likes this.
  7. Brogan

    Brogan XenForo Moderator Staff Member

    I think that just means to switch from one to the other, for those who aren't sure if they're using SSL or not.

    From the same page:

    Outgoing Mail (SMTP) Server - requires TLS3 or SSL
    Port for TLS/STARTTLS: 587
    Port for SSL: 465
     
    GencnesilleR likes this.
  8. Andy.N

    Andy.N Well-Known Member

    What do I have to verify that I can change to TLS and use port 587 if SSL seems to have problems?
     
    GencnesilleR likes this.
  9. Brogan

    Brogan XenForo Moderator Staff Member

    Change the encryption method in the ACP -> Options -> Email Options from SSL to TLS.
     
    GencnesilleR likes this.
  10. Andy.N

    Andy.N Well-Known Member

    Change to TLS and port 587 and still exact same errors as with SSL.
     
    GencnesilleR likes this.
  11. Brogan

    Brogan XenForo Moderator Staff Member

Share This Page