1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Fatal error: Call to undefined method when loading site...

Discussion in 'XenForo Questions and Support' started by Thee, Aug 16, 2013.

  1. Thee

    Thee Active Member

    The full error: Fatal error: Call to undefined method Waindigo_Listener_InitDependencies::compileNamedTemplateInStyleTree() in /kunden/262038_13407/testing/library/Waindigo/Listener/InitDependencies/20130725.php on line 237

    Unfortunately, admin area also gives the same error. any suggestions?

    Happend over night on our testing site without anything being worked on.
     
    Last edited: Aug 16, 2013
  2. JulianD

    JulianD Well-Known Member

    To regain control of your admin area, disable all listeners as explained here (http://xenforo.com/community/threads/quickest-way-to-disable-all-addons.34664/)

    The offending script has to do with some of Waindigo addons, maybe his general library, I don't know. Try to enable one by one, find which one is the culprit and try to reupload all the files of that addon and reimport the xml file.
     
  3. fullenchilada

    fullenchilada Member

    Ok we did it and it worked. Thanx @JulianD

    So now all I gotta do is reupload all the add-ons I had and find out which is causing the problem or just the ones from Waindigo?
     
  4. Jeremy

    Jeremy XenForo Moderator Staff Member

    Just Waindigo's.
     
    JulianD likes this.
  5. fullenchilada

    fullenchilada Member

    Ok worked like a charm. Thanx you guys.
     

Share This Page