• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.3 Facebook login does not work any more

rhodes

Active member
#1
I use xenforo's ability to login with facebook. This worked fine for about a year. But yesterday it stopped working due to a change in Facebooks app policy.

When users try to login they receive the following error message.

facebook-login-error.JPG
When I visit the app permission page
app-permission.JPG
I must enter permissions for my login app. But I'm not sure which one.

Can you please help and tell me how to configure FB apps now so that my users can still use FB login for my xenforo installation?

regards, rhodes
 

Brogan

XenForo moderator
Staff member
#5
It is for mine, but then I'm running the latest XF so I can't comment on how it will work with an older version.
 

rhodes

Active member
#7
Hmm, ok. I'm happy with 1.3 and not amused to update my community to re-enable the facebook login. My plan was to wait till 1.5 or 2.0 as it always is a lot of testing (I have a couple of custom addons). But maybe this is the only way.

What would you recommend? Update to 1.3.2 (is it just a replacement of a few files ?) or jump to the latest version 1.4.6?
 

Mike

XenForo developer
Staff member
#9
The latest within the 1.3 series would generally be a straightforward update, though if you have add-ons, it is important to test them as it's hard to say that they'll work definitively (especially if they're hooking into the system in unexpected places). The ideal would be to stay with the current branch (1.4), but that may not be viable.
 

rhodes

Active member
#10
I have one last question concerning the issue, @Mike . When I try to login this url is called causing the error described above.

https://www.facebook.com/dialog/oau...rthday,user_status,user_website,user_location...

However, when I delete publish_stream from the scope substring login works.

Can you please tell me if this url is called from within xenforo1.3 or is it an url built dynamically by facebook? In the first case I could remove
publish_stream from the template / file as a production workaround until we've tested xf 1.4.5 and all custom addons on our develop environment.