Facebook local language for my XF-website ?

erich37

Well-known member
at each thread here, we have at the very bottom-left the Facebook-box, showing the following text:

"Be the first of your friends to recommend this."

question:
How to change this, so that this text is being shown in my local language (german) ?

Thanks!
 

Brogan

XenForo moderator
Staff member
That should be one of the phrases, unless it is hard coded.

Having said that, it might be part of the Facebook API.
Yes, looking at the code it's all part of the iframe.
 

Gustavo Fernandez

Active member
That should be one of the phrases, unless it is hard coded.

Having said that, it might be part of the Facebook API.
Yes, looking at the code it's all part of the iframe.
I have the same problem

Before updating to beta5 was in Spanish ...

My application on Facebook is in Spanish as well as my username .-

Can you help?
 

Lu Kas

Active member
from here

How do I display the Like button in different languages?

If you are using the XFBML version include the language code when you instantiate the library. Replace ‘en_US’ in this line with the correct locale code:
Code:
'//connect.facebook.net/en_US/all.js';
If you are using the Iframe version include a locale parameter with the proper country code in the src URL. Example:
Code:
src="http://www.facebook.com/widgets/like.php?locale=fr_FR&..."
You may need to adjust the width of the Like button to accommodate different languages.

it is for the like button, maybe it helps for the recommend button too :)
 

Lu Kas

Active member
The Forum standard is XFBML, so there will be anywhere in the xenforo.js some code where you have to change en_US to .. es? spanish for latin america es_LA, or es_ES.
 

Brogan

XenForo moderator
Staff member
The only occurrence of en_us I can find relating to FB is line 3957 of js\xenforo\xenforo.js

I don't think that's going to be what you need though.

I haven't got FB enabled on my dev forum so I can't test it.
 

Lu Kas

Active member
@brogan, it is that easy ... i tried and my forum now says "Sé el primero de tus amigos en recomendar esto."
 

erich37

Well-known member
this is not a XF-bug, it is a matter of which language you have set in your Facebook-account.
 
Top