• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Facebook Integration

#1
I have been having an error message appear when trying to integrate Facebook login. This is the message:

{
"error": {
"message": "Invalid redirect_uri: Given URL is not allowed by the Application configuration.",
"type": "OAuthException",
"code": 191
}
}

Any suggestions?
 

Flexin

Active member
#3
I'm having a problem with mine. This is what I get.

{
"error": {
"message": "Error validating application. Cannot get application info due to a system error.",
"type": "OAuthException",
"code": 101
}
}

James
 

Chris D

XenForo developer
Staff member
#4
Check your Application ID.

Your application ID needs to be entered into Admin CP > Options > Facebook Integration.

You can get it by logging into Facebook Developers http://developers.facebook.com

In the Basic settings of your App it will look like this (but without the details removed, don't reveal these!)

Just make sure both are entered in the Admin CP

appid.PNG
 

Flexin

Active member
#5
Check your Application ID.

Your application ID needs to be entered into Admin CP > Options > Facebook Integration.

You can get it by logging into Facebook Developers http://developers.facebook.com

In the Basic settings of your App it will look like this (but without the details removed, don't reveal these!)

Just make sure both are entered in the Admin CP

View attachment 29803
I have done that before but maybe I used the wrong id. I believe I used the id from my fan page. I went to the developers link you posted but it doesn't show me how to get an id.

James