1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 EXTRA.css not saving

Discussion in 'Troubleshooting and Problems' started by TheJoker, Jun 21, 2012.

  1. TheJoker

    TheJoker Member

    I am working on my localhost, developing a theme, and EXTRA.css won't save. I hit save, (the red 'modified indicator' doesn't go away, but the white popup says it's saved) and then I refresh to see if it worked and it reverts to the last saved version.​
    This is extremely frustrating.​
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Make sure you are not editing the master style (available in debug mode only). Also try relaunching your browser, or try a different browser. I have seen similar problems fixed by relaunching the browser... some kind of client glitch.
     
  3. TheJoker

    TheJoker Member

    I am editing the "Default Style," whether that's the master style or not, I am unsure of as there doesn't seem to be an indicator for that.

    This is happening in both Chrome and Firefox, but thank you for the suggestions. :)
     
  4. TheJoker

    TheJoker Member

    Also occurring in the new test style I just created.
     
  5. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Interesting. Is it only happening with that one template? Do you have any addons installed? If so then try disabling them to see if that affects it.
     
  6. TheJoker

    TheJoker Member

    Yep, only that template, and the only add-on is the vB4-XF importer, which is disabled.
     
  7. Russ

    Russ Well-Known Member

    Try creating a new style, and making changes to extra.css
     
  8. TheJoker

    TheJoker Member

    Did, still not working. I am going to try a fresh-install of XF and see if that does it.
     
  9. TheJoker

    TheJoker Member

    Nope - even with a fresh-install, doing the same thing.
     
  10. TheJoker

    TheJoker Member

    I was tempted to believe that this is being caused by my running PHP 5.4.3 on my localhost, but I didn't have problems with it before tonight....
     
  11. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I can take a look if you give me FTP and admin access.
     
    Shelley likes this.
  12. TheJoker

    TheJoker Member

    It's on my local machine, but thanks! I am going to upload it to my server running PHP 5.3.x and see if that works. If it doesn't, I'll send you some credentials.
     
  13. TheJoker

    TheJoker Member

    Odd. The other changes are saving, but the ones that are not are the ones made to the category header where it has the category description, etc. That won't change without editing the original node_list.css template.
     
  14. Shelley

    Shelley Well-Known Member

    Out of curiosity what is the css your putting in for the category description in the extra.css?

    Code:
    .nodeList .categoryStrip .nodeDescription {
        color: #DCCDBB !important;
        font-size: 11px !important;
        text-shadow: 0 0 0 transparent, 1px 1px 0 #50463B !important;
    }
    
     
  15. TheJoker

    TheJoker Member

    Not that, but it seems to be working now! Thanks everyone!
     
  16. TheJoker

    TheJoker Member

    This problem is unfortunately back.
     
  17. presidentYT

    presidentYT Member

    Im having the same problems.. I'm not sure if this makes a difference.. but ive added the same template twice.. I removed the ability to switch templates.. that way i can work on the template without people switching to it.. I do it manually. So as a i work on the new template.. I've copied extra.css coding that is working on the same template thats active, but wont work on the new template that im adjusting... strange.. and yes i have all the importants added.. still nothing.. no matter what i put in extra css.. nothing adjust...
     
  18. CyclingTribe

    CyclingTribe Well-Known Member

    Are either of you using APC for caching on your local install? If so make sure you don't have apc.stat=0 in your config as it tells it not to check for changes and will keep bringing back previously cached versions of files.

    May be completly unrelated, but thought I'd throw it in - just in case. (y)
     
    Tracy Perry likes this.
  19. presidentYT

    presidentYT Member

    The funny thing is having the same template twice... One works fine with any changes to the CSS the other ignores the extracss
     

Share This Page