1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Every click action needs a secondary refresh to work

Discussion in 'Troubleshooting and Problems' started by billytimmy, Nov 13, 2014.

  1. billytimmy

    billytimmy Member

    This just popped up out of the blue tonight, it seems that every action, such as clicking a forum list needs a refresh to work

    We have removed all add ons and reverted to the default style, there are no errors whatsoever

    here are 2 ways to reproduce the issue, this happens for all users

    1.
    - click on forum
    - create new thread
    - click on the current forum name in top nav
    - new thread is not there in the list of threads
    - hit refresh in browser and now thread displays in the list

    2.
    - start conversation with someone
    - they reply
    - you get pm alert and click it
    - conversation only has the original message
    - hit refresh in browser, reply appears

    but this pattern happens everywhere for everyone.
    notifications are getting stuck pointing to old messages as well

    we had to take the site down over this
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Several customers are reporting similar problems this evening. All appear to be nginx servers with Hostgator. Please contact Hostgator about this. These are the response headers that I have observed:

    Code:
    Cache-control:max-age=86400
    Connection:keep-alive
    Content-Encoding:gzip
    Content-Length:3770
    Content-Type:text/html; charset=UTF-8
    Date:Thu, 13 Nov 2014 06:54:45 GMT
    Expires:Fri, 14 Nov 2014 06:54:45 GMT
    Last-Modified:Thu, 13 Nov 2014 06:54:45 GMT
    Server:nginx/1.6.2
    Vary:Accept-Encoding
    X-Frame-Options:SAMEORIGIN
    
    This is generated by a PHP resource which should not be cached.
     
  3. billytimmy

    billytimmy Member

    Thanks for the quick response guys
     
  4. billytimmy

    billytimmy Member

    for anyone else suffering from this hostgator change I fixed this by adding this to .htaccess

    <IfModule mod_headers.c>
    Header set Cache-Control "no-cache, no-store, must-revalidate"
    Header set Pragma "no-cache"
    Header set Expires 0
    </IfModule>
     

Share This Page