• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Error : vBulletin 3.8 Importer | 'users'

#1
Hello,

I tired to import my data from vBulletin 3.8 Big DataBase ( 700MB) above 13000 users, to XenForo 1.1.1 , i created database name is 'old' by Phpmyadmin then use command line to import my old data, by :
Code:
C:\xampp\mysql\bin>mysql.exe -u root old < old .sql
mysql.exe: Unknown OS character set 'cp720'.
mysql.exe: Switching to the default character set 'latin1'.
 
C:\xampp\mysql\bin>
then i put information for old data in Xenforo to import it. every thing is well, just when import 'users' in 10.5% i got this problem :
Code:
[B][FONT=Tahoma][SIZE=14px]Server Error[/SIZE][/FONT][/B][/SIZE][/SIZE][/FONT][/B]
 
 
[SIZE=14px][FONT=Tahoma][B]Mysqli statement execute error : Duplicate entry '???????' for key 'username'[/B][/FONT][/SIZE]
 
[SIZE=14px][FONT=Tahoma][B]Zend_Db_Statement_Mysqli->_execute() in C:\xampp\htdocs\f\library\Zend\Db\Statement.php at line 297[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]Zend_Db_Statement->execute() in C:\xampp\htdocs\f\library\Zend\Db\Adapter\Abstract.php at line 479[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]Zend_Db_Adapter_Abstract->query() in C:\xampp\htdocs\f\library\Zend\Db\Adapter\Abstract.php at line 574[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]Zend_Db_Adapter_Abstract->insert() in C:\xampp\htdocs\f\library\XenForo\DataWriter.php at line 1591[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]XenForo_DataWriter->_insert() in C:\xampp\htdocs\f\library\XenForo\DataWriter.php at line 1580[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]XenForo_DataWriter->_save() in C:\xampp\htdocs\f\library\XenForo\DataWriter.php at line 1381[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]XenForo_DataWriter->save() in C:\xampp\htdocs\f\library\XenForo\Model\Import.php at line 767[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]XenForo_Model_Import->importUser() in C:\xampp\htdocs\f\library\XenForo\Importer\vBulletin.php at line 1211[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]XenForo_Importer_vBulletin->_importUser() in C:\xampp\htdocs\f\library\XenForo\Importer\vBulletin.php at line 985[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]XenForo_Importer_vBulletin->_importOrMergeUser() in C:\xampp\htdocs\f\library\XenForo\Importer\vBulletin.php at line 774[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]XenForo_Importer_vBulletin->stepUsers() in C:\xampp\htdocs\f\library\XenForo\Importer\Abstract.php at line 77[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]XenForo_Importer_Abstract->runStep() in C:\xampp\htdocs\f\library\XenForo\ControllerAdmin\Import.php at line 180[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]XenForo_ControllerAdmin_Import->_runStep() in C:\xampp\htdocs\f\library\XenForo\ControllerAdmin\Import.php at line 132[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]XenForo_ControllerAdmin_Import->actionImport() in C:\xampp\htdocs\f\library\XenForo\FrontController.php at line 310[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]XenForo_FrontController->dispatch() in C:\xampp\htdocs\f\library\XenForo\FrontController.php at line 132[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]XenForo_FrontController->run() in C:\xampp\htdocs\f\admin.php at line 13[/B][/FONT][/SIZE]
 
[SIZE=14px][FONT=Tahoma][B]
[/B][/FONT][/SIZE]

Also This from Log server-error:

Code:
[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]Error Info[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : Duplicate entry '???????' for key 'username' - library\Zend\Db\Statement\Mysqli.php:214[/B][/FONT][/SIZE]
 
[SIZE=14px][FONT=Tahoma][B]Stack Trace[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]#0 C:\xampp\htdocs\f\library\Zend\Db\Statement.php(297): Zend_Db_Statement_Mysqli->_execute(Array)[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]#1 C:\xampp\htdocs\f\library\Zend\Db\Adapter\Abstract.php(479): Zend_Db_Statement->execute(Array)[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]#2 C:\xampp\htdocs\f\library\Zend\Db\Adapter\Abstract.php(574): Zend_Db_Adapter_Abstract->query('INSERT INTO `xf...', Array)[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]#3 C:\xampp\htdocs\f\library\XenForo\DataWriter.php(1591): Zend_Db_Adapter_Abstract->insert('xf_user', Array)[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]#4 C:\xampp\htdocs\f\library\XenForo\DataWriter.php(1580): XenForo_DataWriter->_insert()[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]#5 C:\xampp\htdocs\f\library\XenForo\DataWriter.php(1381): XenForo_DataWriter->_save()[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]#6 C:\xampp\htdocs\f\library\XenForo\Model\Import.php(767): XenForo_DataWriter->save()[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]#7 C:\xampp\htdocs\f\library\XenForo\Importer\vBulletin.php(1211): XenForo_Model_Import->importUser(1519, Array, '')[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]#8 C:\xampp\htdocs\f\library\XenForo\Importer\vBulletin.php(985): XenForo_Importer_vBulletin->_importUser(Array, Array)[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]#9 C:\xampp\htdocs\f\library\XenForo\Importer\vBulletin.php(774): XenForo_Importer_vBulletin->_importOrMergeUser(Array, Array)[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]#10 C:\xampp\htdocs\f\library\XenForo\Importer\Abstract.php(77): XenForo_Importer_vBulletin->stepUsers(1501, Array)[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]#11 C:\xampp\htdocs\f\library\XenForo\ControllerAdmin\Import.php(180): XenForo_Importer_Abstract->runStep(Object(XenForo_ControllerAdmin_Import), Object(XenForo_ImportSession), 'users', 1501, Array)[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]#12 C:\xampp\htdocs\f\library\XenForo\ControllerAdmin\Import.php(132): XenForo_ControllerAdmin_Import->_runStep(Object(XenForo_Importer_vBulletin), Object(XenForo_ImportSession), 'users', 1501, Array)[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]#13 C:\xampp\htdocs\f\library\XenForo\FrontController.php(310): XenForo_ControllerAdmin_Import->actionImport()[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]#14 C:\xampp\htdocs\f\library\XenForo\FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]#15 C:\xampp\htdocs\f\admin.php(13): XenForo_FrontController->run()[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]#16 {main}[/B][/FONT][/SIZE]
 
 
[SIZE=14px][FONT=Tahoma][B]Request State[/B][/FONT][/SIZE]
 
[SIZE=14px][FONT=Tahoma][B]array(3) {[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]  ["url"] => string(42) "http://localhost/f/admin.php?import/import"[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]  ["_GET"] => array(1) {[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]    ["import/import"] => string(0) ""[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]  }[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]  ["_POST"] => array(1) {[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]    ["_xfToken"] => string(53) "1,1327320974,dc3bb4ddef5e56b56d68bd6b22bf749f639fab6f"[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]  }[/B][/FONT][/SIZE]
[SIZE=14px][FONT=Tahoma][B]}[/B][/FONT][/SIZE]
 
 
 
 
 
 
 
 
[FONT=Tahoma][SIZE=14px][B][/B][/SIZE][/FONT]
Note: character database Xenforo is utf-8

Just import 840 users !!

so how i can fix it??

Thank you[/CODE]
[/CODE][/SIZE][/CODE][/B][/FONT][/SIZE]
 

Brogan

XenForo moderator
Staff member
#2
I have moved your thread from the bugs forum to the correct forum for support.

You will need to associate your forum account with your license before you can post in the customer forums and receive support.