1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Error message on private board's front page

Discussion in 'Troubleshooting and Problems' started by 1361, May 12, 2014.

  1. 1361

    1361 Member

    I have a private board set up at http://worksafe.is/ . This is a fresh install with UI.X theme I have an Error message showing on the front page. Plus the signup button doesn't work. It goes to http://worksafe.is/login/login . What is the normal url for the registration page. I have it set up so non-registered/guest are not allowed to view the board. But they still need to see a landing page with a proper link to register.

    What am I doing wrong?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    It all seems to work as expected as far as I can tell.

    What isn't working for you?
     
  3. borbole

    borbole Well-Known Member

    It loads fine without any error to me as well. What is the exact error that you are getting?
     
  4. 1361

    1361 Member

    This is what I get and the issues I am trying to correct. It might be UI.X theme related also.
    1. Top tab shows an error message
    2. Page error message, but access to the registration page from the for below is possible.
    3. Access to the registration page is possible.
    4. This button doesn't get to anything usable /site.is/login/login. This takes me to another page where I get "This action is available via POST only. Please press the back button and try again." error_message.jpg
     
  5. Tracy Perry

    Tracy Perry Well-Known Member

    #1 - Seems to me that is correct as it is actually an error. they cannot view anything until they log in.
    #2 - See #1
    #3 - To be expected
    #4 - that login is in a notice and is style specific so you need to check the style

    But don't take 1 & 2 as gospel as I don't have my site locked out to all users to make it a totally private site.
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    Yes, all working as expected.

    If you want it to behave differently it will require custom development.
     
  7. rainmotorsports

    rainmotorsports Well-Known Member

    Not sure if you can point the home tab to a Page node with a simple message like the one you already have. If not a simple portal plugin would do that for you and make the index look a little cleaner. But as said before its a private site and users are trying to view something they have no permission to. That is a normal error when visiting a no permission section requiring the user to not be a guest.

    As far as the signup button goes its pointed to the wrong url login/login will always error out when directly linked to. Fix that link and problem solved.
     
  8. 1361

    1361 Member

    I can't figure out the url to the actual login/register page. Or where to edit the info. I have a message on the Audentio board also. I plan to go live ASAP and would like everything looking presentable for my launch.
     
  9. rainmotorsports

    rainmotorsports Well-Known Member

    http://worksafe.is/login/ If you right click on the login button that is stock for xenforo it gives you the fallback that would be the URL if javascript were not pulling down. login/login is the submit page and will always give that error.

    Someone set that message on the login page, someone set that URL. I seriously doubt it was preinstalled like that.
     
  10. Tracy Perry

    Tracy Perry Well-Known Member

    Set in your Style Properties if it is the welcome block.
    Screen Shot 2014-05-12 at 2.41.36 PM.png
     
    rainmotorsports likes this.
  11. 1361

    1361 Member

    This fixed the login button, thanks. Funny thing is, as far as I can tell, the reg. page is site/login/login like it was set. But when you just try and use the url it wont take you to the reg. page. It takes you to a message saying "This action is available via POST only. Please press the back button and try again." But at least the button now takes you to a login page. Thanks
     
  12. rainmotorsports

    rainmotorsports Well-Known Member

    If you right click and open in new tab on the login button at the top of the screen you will see it is /login/, /login/login is a post only page and you will never be able to access the login page from that. That is the page that the login page submits to.
     
  13. 1361

    1361 Member

    Wow, this doesn't seem like something that should be expected. What kind of custom development would it require? Can you do this or at least refer me to someone? The way it is now, it looks like my board is broken.
     
  14. Brogan

    Brogan XenForo Moderator Staff Member

    I think your best option may be something like suggested here: http://xenforo.com/community/threads/error-message-on-private-boards-front-page.73915/#post-764596

    The issue is you have revoked view permissions to the landing/home page of your site (which is the forum index) for guests, hence why the error message is shown.

    You will need to implement a solution which allows both guests and logged in members to access the home/landing page, with relevant information and links to guests to enable them to log in or register.
     
  15. 1361

    1361 Member

    Where would I edit the text under where a user name would be listed on the reg form?
    I want to encourage everyone not to use their real names. regname.jpg
     
  16. Tracy Perry

    Tracy Perry Well-Known Member

    Search phrases for that exact phrase and then edit to suit.

    And to save you some time it is this_is_name_that_will_be_shown_with_your_messages. But still get familiar with using Phrase Search ability. Will save you a lot of time.
     
  17. 1361

    1361 Member

    This worked perfectly.

    I want to thank everyone for helping me through this. This has always just been a hobby for me. This is the first serious endeavor I have undertaken with XenForo.

    So, if I wanted to add a simple portal plugin for a landing page to clean my site up, what would you recommend? What would be the easiest option? I was hoping to go live tomorrow, but I could push it out another day if needed. I would rather not start over. But I will if that's what it takes to get this right. I just don't want it to look broken for my launch. My launch is just handing out flyers at work on days I'm not working.
     
  18. Chris D

    Chris D XenForo Developer Staff Member

    Brogan and Tracy Perry like this.
  19. 1361

    1361 Member

    This looks like a great addition to most sites. As this project will be a private board from the beginning, I don't think this would work out for me. It does have me thinking. Can I make one forum visible to everyone and put my announcements there. I could just lock the threads. Then, when users register, the rest of the board would open up to them. Hmmm, off to play a bit more. It seems like if I used the featured tread add on, I would have to do that anyways , right? Forgive me, just thinking out loud...
     
  20. Jeremy

    Jeremy XenForo Moderator Staff Member

    That is completely possible via the permissions system.
     
    Chris D likes this.

Share This Page