1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Email with local SMTP server

Discussion in 'Troubleshooting and Problems' started by BlackDawn187, Feb 4, 2015.

  1. BlackDawn187

    BlackDawn187 Member


    I'm currently trying to test the email functions of my xenforo forum. I have Xenforo setup and, working. I also have a SMTP server setup and, working. I can send emails by dropping text files in my pickup folder. But, When I set Xenforo to use the SMTP server it doesn't do anything besides print to my server log. The server log says to verify smtp ip/port. The forum is hosted on a Windows Server 2008 R2, Using the built in IIS SMTP server. Any help in resolving the matter is appreciated.

    /Edit: Also, The default email method doesn't work either.
  2. Jim Boy

    Jim Boy Well-Known Member

    WEll firstly it doesn't sound like an XF bug, it sounds like either SMTP isn't setup correctly or you have misconfigured something. For example, if you explicitly given smt credentials, did you use the loopback address ( or the local IP address, you may find that SMTP is bound to only. You can use netstat -na to test. Then there is windows firewall....
  3. Bitwix

    Bitwix Member

    Did you resolve this? I am having the same kind of problem.

    In my case, the OS is Windows Server R2 Standard. I have the Interspire email software, from which I took working values for SMTP Server and Account credentials. Like you, I see an entry in the server log, but no email arrives.

    Annoying, huh?
    Last edited: Feb 16, 2015
  4. BlackDawn187

    BlackDawn187 Member

    I've since dropped the idea of using a local smtp server and, opt'ed for using google. But, I still can't get it to work. I used the tutorial on this page and, I'm getting this error now: "Email to someone@hotmail.com failed: Could not open socket - library\Zend\Mail\Protocol\Abstract.php:277". I'm pretty sure the firewall is blocking the connection, But I don't know how to resolve it. Feels like every things working against me. :cry:

    Also, All new board registrations are failing because of this and, If I opt not to use a smtp server it fails as well.

    Not sure if it's relevant.. But, My php.ini file looks like this under smtp. Pretty sure it has nothing to do with Xenforo though.
    [mail function]
    ; For Win32 only.
    ; http://php.net/smtp
    SMTP = me@example.com
    ; http://php.net/smtp-port
    smtp_port = 20
    ; For Win32 only.
    ; http://php.net/sendmail-from
    sendmail_from = me@example.com
    ; For Unix only.  You may supply arguments as well (default: "sendmail -t -i").
    ; http://php.net/sendmail-path
    ;sendmail_path =
    ; Force the addition of the specified parameters to be passed as extra parameters
    ; to the sendmail binary. These parameters will always replace the value of
    ; the 5th parameter to mail(), even in safe mode.
    ;mail.force_extra_parameters =
    ; Add X-PHP-Originating-Script: that will include uid of the script followed by the filename
    mail.add_x_header = On
    ; The path to a log file that will log all mail() calls. Log entries include
    ; the full path of the script, line number, To address and headers.
    ;mail.log =
    Last edited: Mar 4, 2015
  5. Tracy Perry

    Tracy Perry Well-Known Member

    Is there a particular reason you are using a Windows server?
    Whomever is in charge of your server needs to make sure that the OUTBOUND ports for the connection are open.
    I have seen this happen on a Linux server using CSF in which the ports were locked down to much.
  6. BlackDawn187

    BlackDawn187 Member

    I have root access on the server, I figured the ports are blocked and, I want to enable them. But, I don't know what to supply the firewall with other than the ports. If I just open the ports for the entire system wouldn't that compromise it's security? I only want Xenforo to use the ports, Is there a way I could explicitly specify that or, would simply opening those ports be fine?
  7. Tracy Perry

    Tracy Perry Well-Known Member

    Whatever SMTP port you have set up to use in the ACP for the connection is what you need to open. I'm not familiar with Windows servers and not sure what you are using as a firewall on it.
  8. BlackDawn187

    BlackDawn187 Member

    If there's anyone in the community experienced with Windows Server 2008 R2 that could give me a hand with resolving this issue there may be $50 at the end of the tunnel for you.

    All I want is for Xenforo to be able to send/receive emails via PHP (Not through SMTP). I'm not sure what the exact error is at the moment but I remember it having to do with Zendmail. Might require MX records, But I'm not sure, I recently deleted them after failing to setup SMTP trough Google.

    Getting this up and running is a crucial step, Because without it new members can't register on my website. Prior to moving the website to the previously mentioned server it was hosted by GoDaddy and their system configuration had no issues.

Share This Page