1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Email SMTP problem!

Discussion in 'Troubleshooting and Problems' started by Talon Senatu, Nov 4, 2013.

  1. Talon Senatu

    Talon Senatu New Member

    Hey there,

    My members don't get any email sent from the forum, I searched everywhere but nothing worked.

    These are my settings:
    [​IMG]

    Anyone here knows the issue?
     
  2. Jeremy

    Jeremy XenForo Moderator Staff Member

    Do you have errors in your server logs?
     
  3. Talon Senatu

    Talon Senatu New Member

    Yeah:

    [​IMG]

    Which one do you want to see in detail?
     
  4. Jeremy

    Jeremy XenForo Moderator Staff Member

    Your email provider is refusing your server and thus cannot send emails. I would verify your SMTP settings. After that, you will need to contact your provider to determine a root cause of the rejection.
     
  5. Talon Senatu

    Talon Senatu New Member

    I already contacted my webhost and this was their reply:

     
  6. Jeremy

    Jeremy XenForo Moderator Staff Member

    Your SMTP server is rejecting the connection. You need to determine why it is rejecting it if you have verified your information is correct.
     
  7. Talon Senatu

    Talon Senatu New Member

    That's the problem. I don't know why.
     
  8. Jeremy

    Jeremy XenForo Moderator Staff Member

    You will need to contact your SMTP provider to determine why the connection is being refused.
     
  9. Talon Senatu

    Talon Senatu New Member

    The SMTP comes from GoDaddy, my host...
     
  10. Jeremy

    Jeremy XenForo Moderator Staff Member

    Then you will have to contact GoDaddy to determine why it is refusing the connection from your server.
     
  11. Chris D

    Chris D XenForo Developer Staff Member

    For an e-mail service provider to say they aren't "familiar with that application" frankly shows their ineptitude.

    They provide an SMTP server. XenForo is acting as an SMTP client. They don't need to know anything about XenForo. It's not like you need help setting up nodes and editing templates. You have an SMTP client that can't connect to their SMTP server. If they can't troubleshoot that, I'd recommend finding a different supplier.
     
  12. Talon Senatu

    Talon Senatu New Member

    That's what we are going to do. Our contract runs for another month, then we'll switch.

    But I need an alternative for now.
     
  13. Chris D

    Chris D XenForo Developer Staff Member

    Do you have a Google Apps for Business account?
     
  14. Talon Senatu

    Talon Senatu New Member

    No, I don't. I have been checking it out, but I noticed it's not free to use, but it's a trial?
     
  15. Chris D

    Chris D XenForo Developer Staff Member

    It used to be free.

    Anyway. There's unfortunately not much more you can do.

    Unless you have an SMTP service you can use, you're going to have to use the one from the current host so you'll have to keep on at them until they fix it.
     
  16. Talon Senatu

    Talon Senatu New Member

    That's most unfortunate. Anyway, thanks for the reply!
     
  17. Talon Senatu

    Talon Senatu New Member

    Are there any hosts you can recommend? I've been thinking of Hostgator. They seem good.
     
  18. Chris D

    Chris D XenForo Developer Staff Member

    The Forum Heroes likes this.
  19. The Forum Heroes

    The Forum Heroes Well-Known Member

  20. Talon Senatu

    Talon Senatu New Member

    Thanks for the answers! But I think I'm going with Hostgator.
     

Share This Page