1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Elasticsearch 0.90.5 is out

Discussion in 'Enhanced Search Support' started by Andy.N, Oct 2, 2013.

  1. Andy.N

    Andy.N Well-Known Member

    Adam Howard and CyclingTribe like this.
  2. Andy.N

    Andy.N Well-Known Member

    0.90.6 is out as well as the 1.0.0 beta1
     
  3. Andy.N

    Andy.N Well-Known Member

    0.90.7 is out
     
    Marcus likes this.
  4. MattW

    MattW Well-Known Member

    Are you running the latest version Andy? I'm still on 0.90.5 but it's working and very stable, so I'm trying to hold off all the "latest" version updates as soon as they are released now.
     
  5. Marcus

    Marcus Well-Known Member

    I upgraded to 0.90.7: Overwrote the files and restarted elasticsearch:

    # rcelasticsearch restart

    # curl -XGET 'localhost:9200'
    Did your version number match the updated one?
     
  6. MattW

    MattW Well-Known Member

    Last time I upgraded, you also need to remove the older versions of the files in the es directory, otherwise it will still use them.

    eg:

    Code:
    -rw-r--r-- 1 root root 11000124 Jun 26 08:56 elasticsearch-0.90.2.jar
    -rw-r--r-- 1 root root 10563221 Aug 23 17:07 elasticsearch-0.90.3.jar
    It had both the new and old version in the /lib folder.
     
    Marcus likes this.
  7. Marcus

    Marcus Well-Known Member

    After removing the older files in /elasticsearch/lib and #rcelasticsearch restart I run the updated release now. Thanks!
     
    MattW likes this.
  8. Andy.N

    Andy.N Well-Known Member

    Hahaha, I did upgrade multiple times, and I keep remember the problems @MattW and I run into because we left the old files there.
    I keep referring to the old post he made about doing it the right way. I have no problem using latest version.
     
  9. DRaver

    DRaver Active Member

    Can someone tell me how to upgrade elasticsearch?

    A long time ago I have installed with: dpkg -i elasticsearch-0.90.3.deb

    Now i have download the file elasticsearch-0.90.7.deb

    It is a debian wheezy server.
     
  10. Andy.N

    Andy.N Well-Known Member

    0.90.8 is out
     

Share This Page